Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017 Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
<== Date ==> <== Thread ==>

Subject: RE: caQtDM installation help needed
From: "Antal, Szabolcs" <Szabolcs.Antal@evopro-group.com>
To: Jiro Fujita <jiro.fujita@gmail.com>
Cc: "tech-talk@aps.anl.gov" <tech-talk@aps.anl.gov>
Date: Thu, 19 Oct 2017 15:25:01 +0000
Hi Jiro,

Thanks for your reply!

Meanwhile this morning I also found this article and gave it a try.

After some failed attempts I managed to pass through the build and installation, and I got the binaries.
However when I executed caQtDM it ended up in a Segmentation fault error.

Then I made a fresh virtual machine and restarted the whole process and now it just works fine!

And again thank you all for your help and effort!!!

Yours truly,
____________________
 
Szabolcs Antal
Software Developer

evopro systems engineering Kft.
member of the evopro group



-----Original Message-----
From: Jiro Fujita [mailto:jiro.fujita@gmail.com] 
Sent: Thursday, October 19, 2017 4:09 PM
To: Antal, Szabolcs <Szabolcs.Antal@evopro-group.com>
Cc: Williams Jr., Ernest L. <ernesto@slac.stanford.edu>; tech-talk@aps.anl.gov; jemian@anl.gov
Subject: Re: caQtDM installation help needed

I think your problem is that you aren’t quite using Qt5, although you have it installed.  Here is what I recommend to do; instead of installing Qt5 from qt.io, you may want consider using Qt5 Ubuntu packages.  In fact, as far as I can tell, Pete Jemian has an instruction that probably will work fine for Ubuntu here: 

https://git.aps.anl.gov/jemian/deployments/tree/master/caQtDM/LinuxMint

It is written for LinuxMint instead of Ubuntu, the core is still based on Debian in both cases, so it should work just fine (I think).  At least this way, all the packages needed to install caQtDM is identified for you.  

Jiro

> On Oct 18, 2017, at 11:24 AM, Antal, Szabolcs <Szabolcs.Antal@evopro-group.com> wrote:
> 
> Hi!
> 
> Thank you all for your aid! Unfortunately I cannot get to the final 
> breakthrough :(
> 
> I'm not sure that I made a proper installation for Qt5 and qwt.
> 
> Anyone of you have installed caQtDM on Ubuntu, if so please can you 
> help me get to the right direction because now I'm kinda stuck with this project.
> 
> I can share my installation process so maybe you can find a mistake that can be the root of my troubles:
> 
> Qt5.6.3:
> 
> 	- Downloaded qt-opensource-linux-x64-5.6.3.run
> 	- chmod +x qt-opensource-linux-x64-5.6.3.run
> 	- ./qt-opensource-linux-x64-5.6.3.run
> 	- Followed the instructions within the installer wizard, and set the installation folder to /usr/local/Qt5.6.3
> 	- After a succesful installation I also installed some other dependencies:
> 		- sudo apt-get install mesa-common-dev (installed because qwt install has thrown -> fatal error: GL/gl.h: No such file or directory)
> 		- sudo apt-get install libglu1-mesa-dev (installed because qwt 
> install has thrown -> cannot find -lGL)
> 
> qwt-6.1.3:
> 	- Downloaded qwt-6.1.3.tar.bz2 and extracted it to folder qwt-6.1.3
> 	- cd qwt-6.1.3
> 	- /usr/local/Qt5.6.3/5.6.3/gcc_64/bin/qmake qwt.pro
> 	- make (success)
> 	- sudo make install (success)
> 
> From here I tried several methods to install caQtDM without success, 
> so if anyone of you have hands-on experience with Ubuntu and caQtDM together I'd really appreciate the knowledge share!
> 
> Again thank you all for your efforts!
> 
> Yours truly,
> ____________________
>  
> Szabolcs Antal
> Software Developer
>  
> evopro systems engineering Kft.
> member of the evopro group
> 
> 
> -----Original Message-----
> From: Williams Jr., Ernest L. [mailto:ernesto@slac.stanford.edu]
> Sent: Tuesday, October 17, 2017 3:50 PM
> To: Antal, Szabolcs <Szabolcs.Antal@evopro-group.com>; 
> tech-talk@aps.anl.gov
> Subject: RE: caQtDM installation help needed
> 
> Hi Antal,
> 
> Before attempting to build be sure to setup your environment first:
> 
> I started with Qt5.4.1  ages ago. :)
> An example, follows for those who use the unix bash shell:
> Note: PACKAGE_TOP is the location that you installed your packages ==> Qt5.x and qwt 6.1.x Just replace $PACKAGE_TOP as appropriate with your  "/opt" or "/usr/local"
> **********************************************************************
> ***********************************
> # ==========================================================
> # Let's setup for caQtDM: From PSI
> # Display Editor and Manager for Control System GUI Development # Both 
> Editor/Runtime # Using QT5 and QWT # 
> ==========================================================
> QTDIR=$PACKAGE_TOP/Qt-5.4.1
> QTINC=$PACKAGE_TOP/Qt-5.4.1/include
> QTLIB=$PACKAGE_TOP/Qt-5.4.1/lib
> export QT_PLUGIN_PATH="${QTDIR}/plugins"
> export PATH=$QTDIR/bin:$PATH
> # ==========================================================
> 
> # ==========================================================
> # QWT Setup
> # ==========================================================
> export QWT_ROOT=$PACKAGE_TOP/qwt-6.1.2 export 
> QT_PLUGIN_PATH="${QWT_ROOT}/plugins:$QT_PLUGIN_PATH"
> 
> # ==========================================================
> # Plugin location for caQtDM and epicsQT # 
> ==========================================================
> export QT_PLUGIN_PATH="${EPICS_EXTENSIONS}/lib/${EPICS_HOST_ARCH}:$QT_PLUGIN_PATH"
> # ==========================================================
> 
> **********************************************************************
> *************************
> 
> Note: you can put the above in a file and source it before building 
> caQtDM
> 
> 
> 
> Cheers,
> Ernesto
> ________________________________________
> From: tech-talk-bounces@aps.anl.gov [tech-talk-bounces@aps.anl.gov] on 
> behalf of Antal, Szabolcs [Szabolcs.Antal@evopro-group.com]
> Sent: Tuesday, October 17, 2017 5:33 AM
> To: tech-talk@aps.anl.gov
> Subject: caQtDM installation help needed
> 
> Dear Folks,
> 
> I'm in a bit of trouble with the installation of caQtDM-4.1.5 on Ubuntu 16.04.
> 
> As the installation notes says the prerequisites are Qt5.x and qwt 6.1.x and Qt Designer (however I'm not sure whether I need Qt Designer if I have Qt Creator installed with Qt5.6.3).
> 
> I managed to install Qt5.6.3 to /opt/Qt5.6.3/ and qwt6.1.3 at /usr/local/qwt-6.1.3/.
> 
> I extracted the caQtDM archive to /usr/local/epics/extension/src/caqtdm-4.1.5.
> 
> However I'm not sure how to set the configuration variables inside caQtDM_Env.
> 
> Also a broken qt4 installation can be found on the system and it seems like the caQtDM_Build script tries to use that one during installation as I get the following error message when I run the script:
> 
> qmake: could not exec '/usr/lib/x86_64-linux-gnu/qt4/bin/qmake': No 
> such file or directory
> 
> I'm a bit stuck at the moment, so any help regarding to the overall installation of caQtDM with the mentioned prerequisites would be greatly appreciated!
> 
> Thank you in advance!
> 
> Yours truly,
> ____________________
> 
> Szabolcs Antal
> Software Developer
> 
> 
> [cid:companylogo]
> 
> evopro systems engineering Kft.
> member of the evopro group
> 
> ________________________________
> Ez az e-mail (ideértve annak bármely mellékletét) bizalmas információkat tartalmaz és jogi védelem alatt áll. Az üzenet kizárólag a címzett(ek)nek szól. Amennyiben Ön nem a küldemény címzettje, úgy a téves kézbesítést kérjük haladéktalanul jelezze e-mailben a feladónak és a teljes küldeményt helyreállíthatatlanul törölje. Amennyiben Ön nem az üzenet címzettje, kérjük ne készítsen másolatot az üzenetről, ne továbbítsa, ne tárja fel és ne tegye hozzáférhetővé azt más személy(ek) számára, továbbá semmilyen célra ne használja fel a bizalmas információt: ezen magatartások bármelyike a levéltitok megsértésének minősül.
> 
> Information in this e-mail (including any attachment hereto) is confidential and may be legally privileged. It is intended solely for the attention of the addressee(s). If you received this message in error, please immediately notify the sender by return e-mail and irrecoverably delete the whole message. If you received this e-mail in error, please do not copy it, do not forward, disclose or make it available to other person(s), and do not use the confidential information for any purpose: any such action is regarded as a breach of confidence.


References:
caQtDM installation help needed Antal, Szabolcs
RE: caQtDM installation help needed Williams Jr., Ernest L.
RE: caQtDM installation help needed Antal, Szabolcs
Re: caQtDM installation help needed Jiro Fujita

Navigate by Date:
Prev: Re: caQtDM installation help needed Jiro Fujita
Next: Building an EPICS App for a Linux Target Nab Rahman
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
Navigate by Thread:
Prev: Re: caQtDM installation help needed Jiro Fujita
Next: Re: caQtDM installation help needed Mooney, Tim M.
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
ANJ, 19 Oct 2017 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·