Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  <20102011  2012  2013  2014  2015  2016  2017  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  <20102011  2012  2013  2014  2015  2016  2017 
<== Date ==> <== Thread ==>

Subject: RE: cygwin 1.7 compatibility
From: Ru Igarashi <Ru.Igarashi@lightsource.ca>
To: Mark Rivers <rivers@cars.uchicago.edu>, "tech-talk@aps.anl.gov" <tech-talk@aps.anl.gov>
Date: Fri, 14 May 2010 11:17:03 -0600
Sorry about that, not enough sleep. :)

The problem presented with XMAP hardware, through MXI-4
interfaces.  The symptoms are a big vague.  At first,
the XMAP hardware shows the usual flurry of activity
as the firmware is uploaded and parameters set.  GUIs
update to the default values.  Then when I try to view
the ADC trace, PV connections start to drop throughout
the app.  Attempts to put (via GUI and caput) result
in warning messages that writes have failed.  dbpf on
the iocsh console don't present warnings but neither
is there any apparent action (in the hardware).  seq
threads do start, but I haven't had a chance to look
at any of the diagnostics beyond checking the channel
connections in seq.  I also have not done enough testing
with other apps to say if this is a CA issue or if it
is associated with a particular app or common feature
of apps.  Whatever it is, since the problem went away
with the installation of cygwin 1.5, I believe the
problem is with changes in the base cygwin dll.  Oh,
I forgot to mention that I tried building with gcc3
as well as the default gcc4 in cygwin 1.7, with no
improvement, so I don't think the problem is directly
with gcc (can still be if cygwin*.dll was built with
a buggy gcc4).

The problem may well be new, since cygwin 1.7 was just
released a few months ago.  That was a major revision
according to the web site, and upgrading from 1.5 may
require "some manual changes afterwards".  You should
get a warning message when you try to upgrade or install
using Setup.exe.  They do have a separate "legacy" archive
for 1.5, but I haven't looked closely enough at it to see
what version of packages it contains (it's slated for
Windows 95/98/ME).  My point is, if you want to test on
cygwin 1.7, build a new test box just in case you need to
continue to work in 1.5.  The revert process is a pain.
On the other hand, I haven't determined if EPICS 3.14.10
and later are simply immune to the issue, thus may not
be a problem for EPICS users who upgrade EPICS regularly.

ru

-- 
Ru Igarashi                    Software & Instrumentation Specialist
e-mail: ru.igarashi@usask.ca   Canadian Light Source
ph:306 657 3751                University of Saskatchewan
fax: 306 657 3535              Saskatoon SK S7N 0X4


>-----Original Message-----
>From: Mark Rivers [mailto:rivers@cars.uchicago.edu]
>Sent: 14 May 2010 04:56
>To: Ru Igarashi; tech-talk@aps.anl.gov
>Subject: RE: cygwin 1.7 compatibility
>
>Hi Ru,
>
>What hardware are you talking to?  I think you need to figure
>out which thread or threads is hanging.  When it hangs what
>are the symptoms? Is channel access working either direction?
>I think I am running Cygwin 1.7, but I'll check when I get to
>work.  I have not heard of the problem you are describing,
>and we use Cygwin quite a bit.
>
>Mark



References:
cygwin 1.7 compatibility Ru Igarashi
RE: cygwin 1.7 compatibility Mark Rivers

Navigate by Date:
Prev: Re: MEDM Panels disappeared frequently on Fedora Code 8 32 bit version... Robert Soliday
Next: compiling SDDS, libpng.a Patrick Thomas
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  <20102011  2012  2013  2014  2015  2016  2017 
Navigate by Thread:
Prev: RE: cygwin 1.7 compatibility Mark Rivers
Next: compiling SDDS, libpng.a Patrick Thomas
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  <20102011  2012  2013  2014  2015  2016  2017 
ANJ, 02 Sep 2010 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·