Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017 Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
<== Date ==> <== Thread ==>

Subject: Re: IOC Connecting Problem
From: Pilkyu Jung <pilkyu@bmii.co.kr>
To: Rod Nussbaumer <bomr@triumf.ca>
Cc: tech-talk@aps.anl.gov
Date: Wed, 22 Feb 2017 16:24:27 +0900
Rod:

First of all, I appreciate your advice. It was very helpful.
By the way, I have tried to use port 5024 and 5025.
But, now IOC worked with port 5024, not port 5025.

Can I ask you a question one more?

When I use port 5024, the device worked with telnet automatically.
Like a Image file(16:18:10) that I attached a image file.
However, I guess it should more fast without connecting telnet.
At least, when I connect other device, didn't connect telnet.

and when I use port 5025, it doesn't work.
So, Could you let me know how can I use this oscilloscope on IOC without telnet connecting like other devices?

best regards,
Pilkyu



On 02/16/2017 11:15 PM, Rod Nussbaumer wrote:
Pilkyu:

In your telnet connection, you use port 5024, but in the asyn port connection, you are attempting to use port 5025. This is quite likely one cause of your problem.

Rod Nussbaumer
TRIUMF
Vancouver, Canada

On 02/15/2017 10:29 PM, Pilkyu Jung wrote:
Hi all,


First of all, I am trying to connect from a oscilloscope which name is
Agilent Technologies DSO-X 3052A (500 MHz 4 GSa/s) to IOC.

As you can see in the
manual(http://literature.cdn.keysight.com/litweb/pdf/75019-97073.pdf ,
http://www.keysight.com/upload/cmc_upload/All/3000_series_prog_guide.pdf),

this oscilloscope support a few ways (e.g. the IO Library, Telnet
Sockets, and using Browser Web Control) for sending SCPI.

However, When I connect to IOC, I got a problem. Until now, I just
connected only adjust IP address in st.cmd.


Like this,

drvAsynIPPortConfigure("P1",169.254.90.3:5025,0,0,0)


When I connect by telnet, it is done successfully (please check the
Screenshot...image file).

I don't know why this device can't be connected to IOC in this case.
Definitely I am done with this way before, but now I can't.


Here is my question,


1. Normally, when you connect from device to IOC, what kind of method use?

2. In my case, How can I connect to IOC?


Best Regards,

Pilkyu Jung





Attachment: Screenshot from 2017-02-22 16:18:10.png
Description: PNG image


References:
IOC Connecting Problem Pilkyu Jung
Re: IOC Connecting Problem Rod Nussbaumer

Navigate by Date:
Prev: Re: IOC Connecting Problem Pilkyu Jung
Next: Re: Segmentation fault at dbConvert.c in Ubuntu 32/64 bit Benjamin Franksen
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
Navigate by Thread:
Prev: Re: IOC Connecting Problem Rod Nussbaumer
Next: RE: Re: IOC Connecting Problem Pilkyu Jung
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
ANJ, 22 Feb 2017 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·