Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017 
<== Date ==> <== Thread ==>

Subject: 'reconnect' in asyn / streamDevice
From: Emmanuel Mayssat <emayssat@yahoo.com>
To: epics <tech-talk@aps.anl.gov>
Date: Fri, 11 May 2012 09:51:38 -0700 (PDT)
I have a webserver type device.
The connection 'breaks' at the end of each successful request.

With asyn autoconnect feature, it seems that at least one request should fail for asyn to attempt to reconnect.
With stream, I intended to use the 'connect 1000' at the beginning of my protocols, but it doesn't seem to work.
(Now that I think of it, maybe I should explicitly disconnect at the end)

So currently I have 50% of my requests that fail.
What is the solution?

--
Emmanuel


Replies:
Re: 'reconnect' in asyn / streamDevice Eric Norum
Re: 'reconnect' in asyn / streamDevice Emmanuel Mayssat

Navigate by Date:
Prev: RE: [CA][waveform] how to NELM? Mark Rivers
Next: Re: 'reconnect' in asyn / streamDevice Eric Norum
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017 
Navigate by Thread:
Prev: Re: [CA][waveform] how to NELM? Pavel Masloff
Next: Re: 'reconnect' in asyn / streamDevice Eric Norum
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017 
ANJ, 18 Nov 2013 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·