Argonne National Laboratory

Experimental Physics and
Industrial Control System

2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017 Index 2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
<== Date ==> <== Thread ==>

Subject: Re: EPICS 7.0.1-pre1 (epicsException.h)
From: Andrew Johnson <anj@aps.anl.gov>
To: <core-talk@aps.anl.gov>
Date: Tue, 28 Nov 2017 11:23:06 -0600
Michael,

I will manually apply Dirk's (reversed) patch, do you want to review
these as PRs (both pvDataCPP and pvAccessCPP are modified)?

- Andrew


On 11/28/2017 10:56 AM, Dirk Zimoch wrote:
> I think the attached patch file solves it.
> 
> 
> On 28.11.2017 17:53, Dirk Zimoch wrote:
>> I am trying to get it done right now.
>>
>> But unfortunately after updating core/master, it does not compile any
>> more for my host architecture.
>> And the day end in 7 minutes.
>>
>> I probably send you a patch file instead of what I thinks should work.
>>
>>
>> On 28.11.2017 17:49, Andrew Johnson wrote:
>>> Hi Dirk,
>>>
>>> Michael and I need to know exactly what changes you still need to be
>>> committed for the VxWorks 6.3 and/or 6.7 builds that are not already in
>>> our repositories. Posting the output from 'git diff' rather than just a
>>> description like this is much better, it ensures we don't miss anything.
>>> If you can do that TODAY we'd appreciate it, we're wanting to tag the
>>> -rc1 release, and we'd prefer to have your changes included if possible.
>>>
>>> Thanks,
>>>
>>> - Andrew
>>>
>>> On 11/28/2017 09:39 AM, Dirk Zimoch wrote:
>>>> The __GNUC__ version of the macro SHOW_EXCEPTION from
>>>> modules/pvData/src/misc/pv/epicsException.h crashes g++ version 3.4.4
>>>>
>>>> /afs/psi.ch/project/vxworks/WindRiverGPP3.3/gnu/3.4.4-vxworks-6.3/x86-linux2/bin/../lib/gcc/powerpc-wrs-vxworks/3.4.4/../../../../include/c++/3.4.4/xstring:
>>>>
>>>>
>>>> In function `void testLogicException()':
>>>> /afs/psi.ch/project/vxworks/WindRiverGPP3.3/gnu/3.4.4-vxworks-6.3/x86-linux2/bin/../lib/gcc/powerpc-wrs-vxworks/3.4.4/../../../../include/c++/3.4.4/xstring:78:
>>>>
>>>>
>>>> internal compiler error: in expand_expr_real, at expr.c:8417
>>>> Please submit a full bug report,
>>>> with preprocessed source if appropriate.
>>>> Contact support@windriver.com for instructions.
>>>>
>>>> This can be fixed by using the non-__GNUC__ version for __GNUC__ < 4
>>>>
>>>> #if !defined __GNUC__ || __GNUC__ < 4
>>>> #  define SHOW_EXCEPTION(EI) ::epics::pvData::detail::showException(EI)
>>>>
>>>> With that change, I could finally build EPICS 7 for vxWorks 6.3.
>>>> (Thus the boost header spinlock_pt.hpp is not obsolete.)
>>>

-- 
Arguing for surveillance because you have nothing to hide is no
different than making the claim, "I don't care about freedom of
speech because I have nothing to say." -- Edward Snowdon

Replies:
Re: EPICS 7.0.1-pre1 (epicsException.h) Michael Davidsaver
References:
EPICS 7.0.1-pre1 Andrew Johnson
Re: EPICS 7.0.1-pre1 Dirk Zimoch
Re: EPICS 7.0.1-pre1 (epicsException.h) Dirk Zimoch
Re: EPICS 7.0.1-pre1 (epicsException.h) Andrew Johnson
Re: EPICS 7.0.1-pre1 (epicsException.h) Dirk Zimoch
Re: EPICS 7.0.1-pre1 (epicsException.h) Dirk Zimoch

Navigate by Date:
Prev: Re: EPICS 7.0.1-pre1 (epicsException.h) Dirk Zimoch
Next: Re: EPICS 7.0.1-pre1 (epicsException.h) Michael Davidsaver
Index: 2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
Navigate by Thread:
Prev: Re: EPICS 7.0.1-pre1 (epicsException.h) Dirk Zimoch
Next: Re: EPICS 7.0.1-pre1 (epicsException.h) Michael Davidsaver
Index: 2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
ANJ, 28 Nov 2017 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·