Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017 Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
<== Date ==> <== Thread ==>

Subject: Problems with motor record
From: Jörn Dreyer <j.dreyer@hzdr.de>
To: tech-talk@aps.anl.gov
Date: Tue, 17 Oct 2017 11:07:45 +0200
Hi,

still fighting with the motor record...

I get a strange error message at startup of my IOC:

asynPortDriver:setDoubleParam: port=port1 error setting parameter 19 in list 
0, wrong type
asynMotorController:writeFloat64 error, status=8 axis=0, function=19, 
value=0.000000
devMotorAsyn::asynCallback: m1 pasyn{Float64,Int32}->write returned <empty 
error message>

In my parameter list the number 19 is motorClosedLoop, which indeed is an 
int32 parameter. I'm using basic_asyn_motor.db to setup the motor record.

What goes wrong here?

Regards

Jörn


Replies:
Re: Problems with motor record Torsten Bögershausen
RE: Problems with motor record Mark Rivers

Navigate by Date:
Prev: CSDataQuick beta 2 Wang Xiaoqiang (PSI)
Next: Re: Problems with motor record Torsten Bögershausen
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
Navigate by Thread:
Prev: CSDataQuick beta 2 Wang Xiaoqiang (PSI)
Next: Re: Problems with motor record Torsten Bögershausen
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
ANJ, 17 Oct 2017 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·