Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017 Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
<== Date ==> <== Thread ==>

Subject: Re: PointGrey Firmware
From: Mark Engbretson <engbretson@anl.gov>
To: Mark Rivers <rivers@cars.uchicago.edu>, EPICS Tech Talk <tech-talk@aps.anl.gov>
Date: Wed, 20 Sep 2017 18:02:18 +0000 (UTC)
Thank You,

That answers my question.  Just seemed . . . . odd . . .  that the 'this works for all camera models' firmware is NOT listed on the PointGrey download website when it is a later version than the ones posted. Makes it look as if the generic version for a certain version number might come *first*, and then the model specific  versions appear later. 

me



From: Mark Rivers <rivers@cars.uchicago.edu>
To: 'Mark Engbretson' <engbretson@anl.gov>; EPICS Tech Talk <tech-talk@aps.anl.gov>
Sent: Wednesday, September 20, 2017 11:46 AM
Subject: RE: PointGrey Firmware

Hi Mark,
 
I have a directory containing all of the Point Grey firmware I have downloaded.
 
corvette:~/areaDetectorVendor/PointGrey/Firmware>ls -ltr
total 1092
drwxrwxrwx 3 epics epics     142 Oct 11  2015 GS3-PGE-1.09.3-00
drwxrwxrwx 3 epics epics     139 Oct 15  2015 GS3-U3-1.15.3-00
drwxrwxrwx 2 epics epics     110 Oct 15  2015 GS3-U3-2.08.3-00
drwxrwxrwx 3 epics epics      56 Oct 15  2015 GS3-U3-2.11.3-00
drwxrwxrwx 2 epics epics     109 Oct 15  2015 GS3-U3-2.14.3-00
drwxrwxrwx 3 epics epics      58 Oct 15  2015 BFLY-PGE-1.43.3.0
drwxrwxr-x 3 epics epics     103 Jun  7  2016 GS3-U3-2.23.3-00
drwxrwxrwx 3 epics epics      34 Jun 20  2016 GS3-U3-2.24.3-00-23S6
 
Note that for version 2.23.3 it is a generic version for the entire Grasshopper3 USB-3.0 family of cameras.  For 2.24.3 however I have a version that is specific to the 23S6 model.  I suspect that what they are doing is releasing model-specific versions so they can take advantage of new features or fix bugs quickly, and then as time permits they release a new generic version for all models in that family.
 
I am quite certain I have accidentally tried to flash an incompatible version into a camera, and their flashing software was smart enough to prevent this.  The only problem I have had with their flashing software is with GigE cameras where it would fail if the camera was on a shared network. I had to temporarily make a direct connection from my PC to the camera.  I think the flashing software must not deal well with collisions or something.  I've had no problems flashing USB-3.0 cameras.
 
Mark
 
 
From: Mark Engbretson [mailto:engbretson@anl.gov]
Sent: Wednesday, September 20, 2017 10:25 AM
To: Mark Rivers; EPICS Tech Talk
Subject: PointGrey Firmware
 
 
Mark - Question
 
Historically you have mentioned in Tech-Talk that PointGrey only tends to post the latest firmware on their website once *all* the cameras in a specific model class are know to work. So asking support for the latest versions is suggested, since the posted firmware may be very old and buggy.
 
I did that recently and asked what the firmware was for 3 grasshopper modules and support responded with
 
=============
I have attached a dropbox link below for your new firmware. This is compatible
with all GS3-U3 cameras.
 
gs3-u3-2.31.3-00.ez2
=============
 
However, even the PointGrey website says that
 
=============
Grasshopper3 USB3 Firmware
This is the latest version of firmware for the Grasshopper3 USB3 cameras. Note that the firmware is model specific.
=============
 
Should I assume that Support is correct and that this is indeed a one size fits all firmware package, or at least contains multiple firmware images that will install as required, or is a single image most probably not to work at all. If not, does the camera flashing software have enough intelligence not to update an incorrect firmware? Or be able to restore a legacy firmware if the process fails? I do not have a camera in hand to test and wanted an expert opinion before I walk over to a beam line and start flashing hardware.



References:
PointGrey Firmware Mark Engbretson
RE: PointGrey Firmware Mark Rivers

Navigate by Date:
Prev: Re: dbVerify removed from EPICS 3.16 Michael Davidsaver
Next: Re: dbVerify removed from EPICS 3.16 Andrew Johnson
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
Navigate by Thread:
Prev: RE: PointGrey Firmware Mark Rivers
Next: Re: Ideas / Suggestions for the future of VME-CPU Operating Ambrosch Kristian (PSI)
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
ANJ, 20 Sep 2017 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·