Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017 Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
<== Date ==> <== Thread ==>

Subject: Re: Debian packages for debian 9 (stretch) ?
From: Michael Davidsaver <mdavidsaver@gmail.com>
To: Bo Jakobsen <lister@f77.dk>
Cc: Heine Larsen <heinela@ruc.dk>, tech-talk@aps.anl.gov
Date: Tue, 8 Aug 2017 11:26:45 +0200
Hi Bo,

First, please report specific build failures as bugs against the
appropriate source package.  You don't have to suffer through these
issues alone :)

https://github.com/epicsdeb

wrt. RTEMS...  When I started creating these packages in 2009, I was
also putting together a system based on running RTEMS on some VME
crates.  I found it convenient to have a portable RTEMS development
environment.  Rather than create a separate mechanism, I decided to use
debian packages.

A number of things have changed.  Since leaving BNL I haven't had any
projects involving RTEMS.  Several imo. essential packages (cexp)
haven't been ported to RTEMS 4.10, stalling progress w/ 4.9.6.  RTEMS
now has it's own package manager-ish tool (RTEMS source builder).

You aren't the first to see this as a barrier to progress.  As I'm not
able to support RTEMS packaging anymore, I'll ask if someone else is.
If not, then support can be dropped.

https://github.com/epicsdeb/rtems/issues/9

Michael




On 08/08/2017 09:17 AM, Bo Jakobsen wrote:
> Dear all
> 
> I have been working with our Debian expert on packaging for Debian 9,
> and we are in general having success.
> (I also vote for a public EPICS Debian repository or even better real
> Debian integration).
> 
> However, a number of the packages we are interested in (asyn, calc and
> stream) depend on the rterms package, which seems to be broken.
> 
> We have been able to built the modules by hacking the Debian dependency
> files, and it then seems that the build system lives with the missing
> rterms package.
> 
> As I understand the rterms package it is for supporting different boards
> and not relevant if EPICS ioc's are to be run as soft ioc's on a full
> Linux.
> I was wondering if anyone else have come up with a better solution for
> disabling the rterms dependency, or fixing the rterms package so that it
> builds.
> 
> Best
> Bo
> 
> 
> 
> On 2017-07-27 16:25, Jameson Graef Rollins wrote:
>> On Thu, Jul 27 2017, Bo Jakobsen <lister@f77.dk> wrote:
>>> I have been looking for a good way to integrate EPICS with our debian
>>> based linux system utilizing debian's package system, which this project
>>> nicely provides (thank you).
>> FYI, we're building packages with packaging mostly cloned from:
>>
>> https://github.com/epicsdeb
>>
>> and distributing via internal archives.
>>
>> It would be so great if we could actually get this stuff pushed into
>> Debian proper.
>>
>> jamie.
> 
> 


Replies:
Re: Debian packages for debian 9 (stretch) ? Benjamin Franksen
References:
Debian packages for debian 9 (stretch) ? Carlos Pascual
Re: Debian packages for debian 9 (stretch) ? Carlos Pascual
Re: Debian packages for debian 9 (stretch) ? Carlos Pascual
Re: Debian packages for debian 9 (stretch) ? Michael Davidsaver
Re: Debian packages for debian 9 (stretch) ? Bo Jakobsen
Re: Debian packages for debian 9 (stretch) ? Jameson Graef Rollins
Re: Debian packages for debian 9 (stretch) ? Bo Jakobsen

Navigate by Date:
Prev: Re: Debian packages for debian 9 (stretch) ? Bo Jakobsen
Next: Re: Debian packages for debian 9 (stretch) ? Benjamin Franksen
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
Navigate by Thread:
Prev: Re: Debian packages for debian 9 (stretch) ? Bo Jakobsen
Next: Re: Debian packages for debian 9 (stretch) ? Benjamin Franksen
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
ANJ, 08 Aug 2017 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·