Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017 Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
<== Date ==> <== Thread ==>

Subject: RE: Problem compiling areaDetector-2-5
From: Mark Rivers <rivers@cars.uchicago.edu>
To: Nilson Pereira <nilson.pereira@helmholtz-berlin.de>, Marcin Lukaszewski <Marcin.Lukaszewski@hilase.cz>, "tech-talk@aps.anl.gov" <tech-talk@aps.anl.gov>
Date: Thu, 16 Feb 2017 12:54:12 +0000
> When I mentioned "the latest release" from asyn, I meant the latest package from this link:
> http://www.aps.anl.gov/epics/modules/soft/asyn/
> which is asyn release R4-30, the same version that Marcin was using.

> After I did an asyn checkout from github I had no more compiling errors for area detector. 
> I am assuming the master on github for asyn is release R4-31, correct?

ADCore R2-5 should build fine with asyn R4-30.  However, the master branch of ADCore (soon to be released as R2-6) requires the master branch of asyn (soon to be released as R4-31).

Mark

________________________________________
From: Nilson Pereira [nilson.pereira@helmholtz-berlin.de]
Sent: Wednesday, February 15, 2017 3:06 AM
To: Mark Rivers; Marcin Lukaszewski; tech-talk@aps.anl.gov
Subject: Re: Problem compiling areaDetector-2-5

Hello Mark,

Like I said, I am new to EPICS and it is probably my lack of knowledge
that gets in the way.

When I mentioned "the latest release" from asyn, I meant the latest
package from this link:
http://www.aps.anl.gov/epics/modules/soft/asyn/
which is asyn release R4-30, the same version that Marcin was using.

Unfortunately, I have not kept any logs from my failed trials to be more
specific about it.

After I did an asyn checkout from github I had no more compiling errors
for area detector. I am assuming the master on github for asyn is
release R4-31, correct?

Nilson

On 14.02.2017 19:02, Mark Rivers wrote:
>> My solution was to compile asyn from a git checkout instead if using the latest release.
> What do you mean by "using the latest release".  I would like to know about any problems building areaDetector with either the master branch or any set of compatible tagged releases.
>
> Mark
>
> ________________________________
> From: tech-talk-bounces@aps.anl.gov [tech-talk-bounces@aps.anl.gov] on behalf of Nilson Pereira [nilson.pereira@helmholtz-berlin.de]
> Sent: Tuesday, February 14, 2017 10:39 AM
> To: Marcin Lukaszewski; tech-talk@aps.anl.gov
> Subject: Re: Problem compiling areaDetector-2-5
>
>
> Hello Marcin,
>
> I am new to EPICS and I am not sure I will be able to help. Anyway, recently, I had a lot of trouble compiling area detector as well. The compiling errors were different than yours but maybe they have the same source.
> My solution was to compile asyn from a git checkout instead if using the latest release.
>
> This was my setup:
>
> Ubuntu 16.04 LTS
> EPICS Base R3.15.5
> Asyn R4-31 (Head of Master on git - 19.1.2017)
> Autosave R5.7.1
> Busy R1.6.1
> Calc R.3.61
> Sequencer R2.2.4
> SScan R2.10
> Area Detector R2.5 with modules (Head of Master on git - 19.1.2017):
> ADCore R2.5
> NDDriverStdArrays R1.0
> ADSupport R1.0
>
> That is quick to try and I hope it works.
>
> Nilson
>
> On 14.02.2017 17:00, Marcin Lukaszewski wrote:
> Hi all,
>
> I am trying to compile areaDetector R2-5 on Ubuntu 16.04 LTS
> I git clone areaDetector, ADCore, ADSupport and ADExample and git checkout to following versions:
>
> areaDetector R2-5
> ADCore R2-5
> ADSupport R1-0
> ADExample R2-2
>
> EPICS setup:
> base 3.15.4
> asyn-4-30
> autosave-5-7-1
> busy-1-6-1
> calc-3-4-2-1
> seq-2-23
> sscan-2-10-1
>
> Below pasties to my areaDetector/configure files:
>
> - areaDetector folder structure   http://pastebin.com/5KmLn7Cb
> - RELEASE_PATHS.local                http://pastebin.com/JbzKhrTE
> - RELEASE_LIBS.local                     http://pastebin.com/Eus4L5Fi
> - RELEASE_PRODS.local                http://pastebin.com/gDSyG2JT
> - CONFIG_SITE.LOCAL                  http://pastebin.com/C7iumVfN
> - RELEASE.local                               http://pastebin.com/a0BsWNAs
>
> After setup above I am trying to make but compilation terminates with the error:
>
> /usr/bin/g++  -D_GNU_SOURCE -D_DEFAULT_SOURCE            -D_X86_64_  -DUNIX  -Dlinux     -O3 -g   -Wall     -DH5_NO_DEPRECATED_SYMBOLS -DH5Dopen_vers=2 -DH5Gcreate_vers=2  -mtune=generic     -m64 -fPIC -I. -I../O.Common -I. -I. -I.. -I../../../include/compiler/gcc -I../../../include/os/Linux -I../../../include       -I/home/eli_sw/epics/R3.15/include/compiler/gcc -I/home/eli_sw/epics/R3.15/include/os/Linux -I/home/eli_sw/epics/R3.15/include      -I/home/eli_sw/epics/support/asyn-4-30/include      -I/home/eli_sw/epics/support/areaDetector-2-5/ADCore/include                    -I/usr/local64/include  -I/usr/include/libxml2     -c ../PosPluginWrapper.cpp
> In file included from ../PosPluginWrapper.cpp:8:0:
> ../PosPluginWrapper.h:11:25: fatal error: NDPosPlugin.h: No such file or directory
> compilation terminated.
> /home/eli_sw/epics/R3.15/configure/RULES_BUILD:234: recipe for target 'PosPluginWrapper.o' failed
> make[4]: *** [PosPluginWrapper.o] Error 1
> make[4]: Leaving directory '/home/eli_sw/epics/support_5_8_at15/areaDetector-2-5/ADCore/ADApp/pluginTests/O.linux-x86_64'
> /home/eli_sw/epics/R3.15/configure/RULES_ARCHS:61: recipe for target 'install.linux-x86_64' failed
> make[3]: *** [install.linux-x86_64] Error 2
> make[3]: Leaving directory '/home/eli_sw/epics/support_5_8_at15/areaDetector-2-5/ADCore/ADApp/pluginTests'
> /home/eli_sw/epics/R3.15/configure/RULES_DIRS:88: recipe for target 'pluginTests.install' failed
> make[2]: *** [pluginTests.install] Error 2
> make[2]: Leaving directory '/home/eli_sw/epics/support_5_8_at15/areaDetector-2-5/ADCore/ADApp'
> /home/eli_sw/epics/R3.15/configure/RULES_DIRS:88: recipe for target 'ADApp.install' failed
> make[1]: *** [ADApp.install] Error 2
> make[1]: Leaving directory '/home/eli_sw/epics/support_5_8_at15/areaDetector-2-5/ADCore'
> /home/eli_sw/epics/R3.15/configure/RULES_DIRS:88: recipe for target '/home/eli_sw/epics/support/areaDetector-2-5/ADCore.install' failed
> make: *** [/home/eli_sw/epics/support/areaDetector-2-5/ADCore.install] Error 2
>
> Full output you can find here: http://pastebin.com/y06WGJwX
>
> Quick check if I have files in correct places gives me:
>
> /home/eli_sw/epics/support/areaDetector-2-5
> → find -name "NDPosPlugin.h"
> ./ADCore/ADApp/pluginSrc/NDPosPlugin.h
>
> /home/eli_sw/epics/support/areaDetector-2-5
> → find -name "PosPluginWrapper.h"
> ./ADCore/ADApp/pluginTests/PosPluginWrapper.h
>
>
> What I am doing wrong? Is there anything else I have to setup to compile areaDetector?
>
> Marcin
>
>
> ________________________________
>
> Helmholtz-Zentrum Berlin für Materialien und Energie GmbH
>
> Mitglied der Hermann von Helmholtz-Gemeinschaft Deutscher Forschungszentren e.V.
>
> Aufsichtsrat: Vorsitzender Dr. Karl Eugen Huthmacher, stv. Vorsitzende Dr. Jutta Koch-Unterseher
> Geschäftsführung: Prof. Dr. Anke Rita Kaysser-Pyzalla, Thomas Frederking
>
> Sitz Berlin, AG Charlottenburg, 89 HRB 5583
>
> Postadresse:
> Hahn-Meitner-Platz 1
> D-14109 Berlin
>
> http://www.helmholtz-berlin.de


________________________________

Helmholtz-Zentrum Berlin für Materialien und Energie GmbH

Mitglied der Hermann von Helmholtz-Gemeinschaft Deutscher Forschungszentren e.V.

Aufsichtsrat: Vorsitzender Dr. Karl Eugen Huthmacher, stv. Vorsitzende Dr. Jutta Koch-Unterseher
Geschäftsführung: Prof. Dr. Anke Rita Kaysser-Pyzalla, Thomas Frederking

Sitz Berlin, AG Charlottenburg, 89 HRB 5583

Postadresse:
Hahn-Meitner-Platz 1
D-14109 Berlin

http://www.helmholtz-berlin.de


References:
Problem compiling areaDetector-2-5 Marcin Lukaszewski
Re: Problem compiling areaDetector-2-5 Nilson Pereira
RE: Problem compiling areaDetector-2-5 Mark Rivers
Re: Problem compiling areaDetector-2-5 Nilson Pereira

Navigate by Date:
Prev: RE: Problem compiling areaDetector-2-5 Mark Rivers
Next: Re: IOC Connecting Problem Rod Nussbaumer
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
Navigate by Thread:
Prev: Re: Problem compiling areaDetector-2-5 Nilson Pereira
Next: Re: Problem compiling areaDetector-2-5 Andrew Johnson
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
ANJ, 16 Feb 2017 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·