Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017 Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
<== Date ==> <== Thread ==>

Subject: Re: Multiple OS Build
From: Ralph Lange <ralph.lange@gmx.de>
To: Andrew Johnson <anj@aps.anl.gov>
Cc: EPICS Tech Talk <tech-talk@aps.anl.gov>
Date: Mon, 9 Jan 2017 19:31:50 +0100


On Mon, Jan 9, 2017 at 7:06 PM, Andrew Johnson <anj@aps.anl.gov> wrote:

The approach that we use here at APS for extensions such as MEDM (which
we install on a shared drive) is to always build these tools on the
oldest OS version that we currently support, and ensure that any newer
OSs always install the necessary backwards-compatibility packages that
provide older .so versions of the system libraries so those older OS
binaries will run properly on the newer OS. This works for us on RHEL,
but I don't know if Debian provides those kinds of packages.

In most cases Debian does not need that, as each shared library usually has the SONAME as part of the package name, so that multiple versions of the same library can coexist on a single host.
(Something that is purely conventional and RedHat deliberately does not do, thus requiring the -compat package workaround.)

Nevertheless, packaging might be the better option, if you have to support multiple (if not many) versions of the same Linux flavor.

~Ralph
 

References:
Multiple OS Build Hugo Slepicka
Re: Multiple OS Build Andrew Johnson

Navigate by Date:
Prev: RE: Asyn and devices with changing register map Mooney, Tim M.
Next: Re: Multiple OS Build Ron Sluiter
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
Navigate by Thread:
Prev: Re: Multiple OS Build Andrew Johnson
Next: Re: Multiple OS Build Ron Sluiter
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
ANJ, 14 Feb 2017 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·