g+
g+ Communities
Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014 
<== Date ==> <== Thread ==>

Subject: Re: Problem with medmfonts.ali running under Ubuntu 1204
From: Ivan Kohler <ivan@tlabs.ac.za>
To: Andrew Johnson <anj@aps.anl.gov>
Cc: tech-talk@aps.anl.gov
Date: Tue, 27 Nov 2012 15:23:56 +0200
Hi Andrew,
I finally to around to finding the library to give me all the larger fonts for MEDM running under Ubuntu 1204.
Just apt-get install xfont-100dpi.
It also works for Ubuntu 12.10.
By default Ubuntu 10.04 loaded this package, but this is not so for 12.04 and up. I didn't check it for 11.04 or 11.10
Thanks for the help
Ivan

On 05/09/2012 18:11, Andrew Johnson wrote:
Hi Ivan,

On 2012-09-05 Ivan Kohler wrote:
I seem to be having a fonts problem running medm under Ubuntu 1204
I did the usual cat of medmfonts.ali >>
/usr/share/fonts/X11/misc/fonts.alias the found that all fonts
larger than 22 points were missing when I ran medm.  Any thoughts?

That means Ubuntu 12.04 must have removed those fonts from their default
distribution.

Could this be an open source license issue for these fonts?

I very much doubt it, since they have been used and distributed for years with
no problems, and I other distros do still include them.

Ubuntu probably has the fonts still available somewhere, you just have to find
what package they're in and install it.  If you find the answer please let us
know. On RHEL 6.2 the Sony fonts are in xorg-x11-fonts-misc-7.2-9.1.el6.noarch
and the Adobe fonts are in xorg-x11-fonts-ISO8859-1-100dpi-7.2-9.1.el6.noarch
so I'm guessing they're an optional part of X11 v7.2 which Ubuntu no longer
installs by default.

- Andrew



References:
Problem with medmfonts.ali running under Ubuntu 1204 Ivan
Problem with medmfonts.ali running under Ubuntu 1204 Ivan Kohler
Re: Problem with medmfonts.ali running under Ubuntu 1204 Andrew Johnson

Navigate by Date:
Prev: posix osiSpawnDetachedProcess inherits scheduling policy + priority Till Straumann
Next: Re: caRepeater object code not cross-compiled in R3.14.12.2 Jack Smith
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014 
Navigate by Thread:
Prev: Re: Problem with medmfonts.ali running under Ubuntu 1204 Andrew Johnson
Next: Motor Record 6-5-2 backlash issue? Márcio Paduan Donadio
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014 
ANJ, 18 Nov 2013 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICSv4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·