Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017 Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
<== Date ==> <== Thread ==>

Subject: Re: EPICS 7 Release Candidate 1
From: Michael Davidsaver <mdavidsaver@gmail.com>
To: Mark Rivers <rivers@cars.uchicago.edu>, "Peterson, Kevin M." <kmpeters@anl.gov>, "Johnson, Andrew N." <anj@aps.anl.gov>, EPICS tech-talk <tech-talk@aps.anl.gov>
Date: Wed, 6 Dec 2017 09:20:18 -0500
On 12/06/2017 08:44 AM, Mark Rivers wrote:
> Hi Michael,
> 
> 
> Following the MSDN link in your message it says that the option /std:c++14 is supported in VS2015.  In fact it says this:
> 
> 
> The /std:c++14 and /std:c++latest options are available beginning in Visual C++ 2013 Update 3.
> 
> 
> However, I just did some Google searching, and it appears that the line above may actually be a typo, because other sources indicate that this option was added in Visual C++ 2015 Update 3, not 2013.  That would explain why it is not working for me.
> 
> 
> I am not sure if it is possible to update the Community Edition 2015 to Update 3, or if I need to install 2017.  Does anyone else know?
> 
> 
> Do you plan to require using either 2010 (which works) or 2015 Update 3 or 2017 (assuming they work) for EPICS 7?  Or will the code be changed to work with these older compilers?

I'll try my best to make it work in both cases.  It's more a question of having a test environment.


> Mark
> 
> 
> 
> ________________________________
> From: tech-talk-bounces@aps.anl.gov <tech-talk-bounces@aps.anl.gov> on behalf of Michael Davidsaver <mdavidsaver@gmail.com>
> Sent: Tuesday, December 5, 2017 9:07 PM
> To: Peterson, Kevin M.; Johnson, Andrew N.; EPICS tech-talk
> Subject: Re: EPICS 7 Release Candidate 1
> 
> On 12/05/2017 03:17 PM, Peterson, Kevin M. wrote:
>> d:\epics7\base-7.0.1-rc1\modules\pva2pva\pdbapp\pdbgroup.h(136): note: see declaration of 'PDBGroupChannel'
>> ../pdb.cpp(61): error C2664: 'std::shared_ptr<PVIFBuilder>::shared_ptr(std::shared_ptr<PVIFBuilder> &&) noexcept': cannot convert argument 1 from 'std::auto_ptr
>> <PVIFBuilder>' to 'std::auto_ptr<PVIFBuilder> &&'
> 
> hmm, seems like that MSVC implementation of shared_ptr doesn't have all of the constructor overloads.
> Maybe they've just jumped the gun by removing the deprecated (in c++17) form, even when building in c++98?
> 
> http://en.cppreference.com/w/cpp/memory/shared_ptr/shared_ptr
> 
> Can you try to rebuild everything in >= c++11 mode by adding the "/std" compiler flag?
> When built with >= c++11 compatibility, unique_ptr is used instead of (deprecated) auto_ptr here.
> 
> https://msdn.microsoft.com/en-us/library/mt490614.aspx
> 


Replies:
RE: EPICS 7 Release Candidate 1 Mark Rivers
References:
EPICS 7 Release Candidate 1 Andrew Johnson
Re: EPICS 7 Release Candidate 1 Peterson, Kevin M.
Re: EPICS 7 Release Candidate 1 Michael Davidsaver
Re: EPICS 7 Release Candidate 1 Mark Rivers

Navigate by Date:
Prev: Re: EPICS 7 Release Candidate 1 Mark Rivers
Next: Re: How to configure and build ca2aa for converting files from Channel Archiver to Archiver Appliance Shen, Guobao
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
Navigate by Thread:
Prev: Re: EPICS 7 Release Candidate 1 Mark Rivers
Next: RE: EPICS 7 Release Candidate 1 Mark Rivers
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
ANJ, 06 Dec 2017 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·