Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017 Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
<== Date ==> <== Thread ==>

Subject: RE: Andor shamrock not detected
From: Mark Rivers <rivers@cars.uchicago.edu>
To: 'Hinko Kocevar' <hinkocevar@gmail.com>, "tech-talk@aps.anl.gov" <tech-talk@aps.anl.gov>
Date: Fri, 1 Dec 2017 16:51:12 +0000
Hi Hinko,

Is this Linux or Windows?

What version of ADAndor?

Did it ever work, or is this the first time you have tried it.

I do recall some people at the APS having trouble with the Shamrock under Linux, but I think they did get it working.  It is working fine for me under Windows.

Mark


> -----Original Message-----
> From: tech-talk-bounces@aps.anl.gov [mailto:tech-talk-bounces@aps.anl.gov] On Behalf
> Of Hinko Kocevar
> Sent: Friday, December 01, 2017 10:31 AM
> To: tech-talk@aps.anl.gov
> Subject: Andor shamrock not detected
> 
> Hi,
> 
> I have trouble talking to Andor shamrock spectrograph.
> It fails after calling Andor API:
> 
> error = ShamrockGetNumberDevices(&numDevices);
> 
> because numDevices evaluates to < 1.
> 
> If I try with Andor supplied C example it works fine, I can control
> the spectrograph.
> 
> Here is what the example does for initialization - and it does not
> look any different, AFAICT, from what EPICS AD Andor support does:
> 
> 
>         //Initialize CCD
>         error = Initialize("/usr/local/etc/andor-2.102.30001.0");
>         if(error!=DRV_SUCCESS){
>                 cout << "Initialisation error: " << error << "
> ...exiting" <<endl;
>                 return(1);
>         }
>         cout << "Camera ready!" << endl;
>         //Initialize Shamrock CCD
>         error = ShamrockInitialize("");
>         if(error!=SHAMROCK_SUCCESS){
>                 cout << "Initialisation error: " << error << "
> ...exiting" <<endl;
>                 ShutDown();
>                 return(1);
>         }
>         cout << "Shamrock ready!" << endl;
>         int nodevices(0);
>         ShamrockGetNumberDevices(&nodevices);
>         if(nodevices < 1) {
>                 cout << "No Shamrock detected...exiting" <<endl;
>                 ShamrockClose();
>                 ShutDown();
>                 return(1);
>         }
> 
> 
> Han anyone had similar issues?
> 
> --
> 
> Thanks,
> Hinko

Replies:
RE: Andor shamrock not detected Mark Rivers
References:
Andor shamrock not detected Hinko Kocevar

Navigate by Date:
Prev: RE: dbGetLink question Mark Rivers
Next: Re: BOY detached opi remains in front of its parent Paul Sichta
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
Navigate by Thread:
Prev: Andor shamrock not detected Hinko Kocevar
Next: RE: Andor shamrock not detected Mark Rivers
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
ANJ, 01 Dec 2017 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·