Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017 Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
<== Date ==> <== Thread ==>

Subject: Re: Using VDCT for EPICS 3.15.5
From: Nab Rahman <nrahman@pppl.gov>
To: "Kasemir, Kay" <kasemirk@ornl.gov>
Cc: "tech-talk@aps.anl.gov" <tech-talk@aps.anl.gov>
Date: Wed, 29 Nov 2017 15:44:43 -0500
Hi Kay,

Yes I did notice with some thorough testing that the 3.14's base.dbd file can be used to create database records for 3.15. It has something to do with that new "GUI menu" setup seen in the dbCommon.dbd file. 

Thanks for the notice Kay - it helps to know I'm not the only one in this quandary. 

- Nab 

On Wed, Nov 29, 2017 at 3:09 PM, Kasemir, Kay <kasemirk@ornl.gov> wrote:

Hi:


I saw the same problem.

When I mentioned it to Andrew, he had some ideas which new *.dbd content might confuse VDCT.

For most intends and purposes you can edit "new" *.db files with the "old" base.dbd, though.


Another problem that I saw on a recent Linux was the refresh for the dialog boxes.

The dialogs for creating a new record as well as the property dialog were initially empty.

Had to force a refresh by selecting another application, then the dialog again.


-Kay





From: tech-talk-bounces@aps.anl.gov <tech-talk-bounces@aps.anl.gov> on behalf of Nab Rahman <nrahman@pppl.gov>
Sent: Wednesday, November 29, 2017 2:54 PM
To: tech-talk@aps.anl.gov
Subject: Using VDCT for EPICS 3.15.5
 
Hello, 

I am currently using EPICS Base 3.15.5 with a linux x86_64 machine and am a relatively new user to EPICS. 

I would like to use VDCT to build EPICS databases for EPICS 3.15.5 (stable release) and noticed that VDCT will not load the base version "base.dbd" file found in the base directory. I have been able to successfully load VDCT with EPICS 3.14.12.6's "base.dbd" file but not with EPICS 3.15.5 

I took a look at the contents of the .dbd files for both versions to compare and noticed they are almost the same except for the following: 
  • "menuScan.dbd" - NEW file 
  • "filters.dbd" - NEW file 
  • Record types have now been sent to a separate record file called "stdRecords.dbd" which contains same record files
  • "devSoft.dbd" has a new GUI group than how it's stated in 3.14 - seems to be the issue
I can load "devSoft.dbd" for EPICS 3.15.5 and VDCT will open and show a blank template but unable to add other dbd files. 

Has anyone in the EPICS community been able to successfully run VDCT with EPICS 3.15.5? 

Thanks for the help,
Nab 


References:
Using VDCT for EPICS 3.15.5 Nab Rahman
Re: Using VDCT for EPICS 3.15.5 Kasemir, Kay

Navigate by Date:
Prev: Re: Using VDCT for EPICS 3.15.5 Kasemir, Kay
Next: Re: Using VDCT for EPICS 3.15.5 Andrew Johnson
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
Navigate by Thread:
Prev: Re: Using VDCT for EPICS 3.15.5 Kasemir, Kay
Next: Re: Using VDCT for EPICS 3.15.5 Andrew Johnson
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
ANJ, 29 Nov 2017 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·