Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017 Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
<== Date ==> <== Thread ==>

Subject: Re: Using VDCT for EPICS 3.15.5
From: Andrew Johnson <anj@aps.anl.gov>
To: Nab Rahman <nrahman@pppl.gov>, <tech-talk@aps.anl.gov>
Date: Wed, 29 Nov 2017 14:44:58 -0600
Hi Nab,

On 11/29/2017 01:54 PM, Nab Rahman wrote:
> I would like to use VDCT to build EPICS databases for EPICS 3.15.5
> (stable release) and noticed that VDCT will not load the base version
> "base.dbd" file found in the base directory. I have been able to
> successfully load VDCT with EPICS 3.14.12.6's "base.dbd" file but not
> with EPICS 3.15.5 

> Has anyone in the EPICS community been able to successfully run VDCT
> with EPICS 3.15.5? 

I just tried and can successfully load the softIoc.dbd file from Base
3.15.5. This is the DBD that has all the includes expanded out for all
the record and device types that come with Base.

In general you should first create your IOC application area (with
makeBaseApp) and configure its configure/RELEASE file, then run make to
create the IOC's DBD file and load that from the $TOP/dbd directory into
VDCT. It will then know about all the record and device types that the
IOC knows about. You shouldn't have to load more than that one DBD file.

Kay's point about new DBD syntax in newer releases is true, VDCT
v2.6.1280 cannot load a softIoc.dbd file from Base-3.16.1 or the
soon-to-be-released Base-7.0.1, so as a community we have some work to
do to update it — any volunteers out there with Java experience please?

- Andrew

-- 
Arguing for surveillance because you have nothing to hide is no
different than making the claim, "I don't care about freedom of
speech because I have nothing to say." -- Edward Snowdon

Replies:
Re: Using VDCT for EPICS 3.15.5 Nab Rahman
References:
Using VDCT for EPICS 3.15.5 Nab Rahman

Navigate by Date:
Prev: Re: Using VDCT for EPICS 3.15.5 Nab Rahman
Next: EPID bumpless restart Crisp, Daniel
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
Navigate by Thread:
Prev: Re: Using VDCT for EPICS 3.15.5 Nab Rahman
Next: Re: Using VDCT for EPICS 3.15.5 Nab Rahman
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
ANJ, 29 Nov 2017 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·