Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017 Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
<== Date ==> <== Thread ==>

Subject: RE: mrfioc2 release 2.2.0 (Supports VME-EVM-300 & VME-EVR-300 or not?)
From: "Kalantari Babak (PSI)" <babak.kalantari@psi.ch>
To: "Wang, Lin" <wanglin@ihep.ac.cn>
Cc: EPICS Tech-Talk <tech-talk@aps.anl.gov>
Date: Tue, 17 Oct 2017 14:56:17 +0000
Hi Lin,

At PSI we use our mrfioc2 fork on Linux kernels 3.14.23 or 4.9.0 on IFC1210 board from IOxOS. For 3.14.23  we use both vanilla and rt, for 4.9.0 only rt flavor.  
As Tony mentioned, he has recently got it run also on  VxWorks 6.9. 

Our fork supports all latest features of 300 series (EVM and EVR) on PCIe and VME form-factors.

Regards,
Babak


-----Original Message-----
From: tech-talk-bounces@aps.anl.gov [mailto:tech-talk-bounces@aps.anl.gov] On Behalf Of Wang, Lin
Sent: Montag, 16. Oktober 2017 16:25
To: Michael Davidsaver
Cc: EPICS Tech-Talk
Subject: Re: mrfioc2 release 2.2.0 (Supports VME-EVM-300 & VME-EVR-300 or not?)


> Do you have some specific requirement driving the use of vxWorks/VME, 
> or is this a matter of familiarity and experience?

We are familiar with VxWorks, but Linux is also acceptable. At this moment, We do not have any real-time performance requirement yet.


> To me, Linux is a much
> more forgiving environment than RTEMS/vxWorks.  I've found non-RT 
> Linux to be more than capable of meeting the 10ms cycle deadline of 
> FRIB.  PSI reported a similar experience with RT Linux at the last week.

If we choose Linux, which Linux distribution would you recommend for running mrfioc2? Which Linux distribution do you and PSI use for running or testing mrfioc2?


Thanks,
Lin


References:
mrfioc2 release 2.2.0 Michael Davidsaver
Re: mrfioc2 release 2.2.0 (Supports VME-EVM-300 & VME-EVR-300 or not?) Wang, Lin
Re: mrfioc2 release 2.2.0 (Supports VME-EVM-300 & VME-EVR-300 or not?) Michael Davidsaver
Re: mrfioc2 release 2.2.0 (Supports VME-EVM-300 & VME-EVR-300 or not?) Wang, Lin

Navigate by Date:
Prev: Re: caQtDM installation help needed Mooney, Tim M.
Next: Re: mrfioc2 release 2.2.0 Jeong Han Lee
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
Navigate by Thread:
Prev: Re: mrfioc2 release 2.2.0 (Supports VME-EVM-300 & VME-EVR-300 or not?) Michael Davidsaver
Next: Re: mrfioc2 release 2.2.0 Jeong Han Lee
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
ANJ, 17 Oct 2017 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·