Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017 Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
<== Date ==> <== Thread ==>

Subject: Re: Ideas / Suggestions for the future of VME-CPU Operating Systems
From: Heinz Junkes <junkes@fhi-berlin.mpg.de>
To: Goetz Pfeiffer <Goetz.Pfeiffer@helmholtz-berlin.de>
Cc: EPICS tech-talk <tech-talk@aps.anl.gov>
Date: Wed, 20 Sep 2017 16:37:04 +0200
Hello Goetz,

at the FHI (in Berlin ;-) ) we run RTEMS 4.12 with EPICS 3.16 on beatnik-boards (MVME6100)
and MVME2500 boards with success.

I can provide a RTEMS - EPICS 4.12 pre-release for MVME6100.

Hope to incorporate it final into epics-base by next 2-3 months.

I haven’t port cexp to rtems 4.12, would be happy for help ;-)

We setup new experiments still with VME bus systems. 

Best regards,
Heinz

> On 20 Sep 2017, at 11:28, Goetz Pfeiffer <Goetz.Pfeiffer@helmholtz-berlin.de> wrote:
> 
> Hello,
> 
> at the Helmholtz-Zentrum Berlin (https://www.helmholtz-berlin.de/) we use EPICS for our control system.
> We have a growing number of soft IOCs with Linux and VME bus based IOCs mostly running RTEMS and 
> some vxWorks 5.4 (Tornado 2.02).
> 
> Our CPU boards are MVME162 and MVME2100. We have replaced more than half of the old MVME162 boards with
> MVME2100 boards, of which we bought a large supply some years ago.
> After migrating most VME CPUs to RTEMS 4.9 we have run into some problems:
> 
> 	• Newer CPU boards like the MVME5500 require the "beatnik" board support, which only works with RTEMS 4.10
> 	• RTEMS 4.10 has some problems regarding the "cexp" shell and doesn't work on some of our IOCs.
> 	• cexp, the shell for RTEMS is not compatible with RTEMS 4.11 and 4.12, but we need it for dynamic loading of objects
> 	• gesys, the component that is used to create the RTEMS kernel seems to be a bit of a mess
> 	• RTEMS 4.11 and 4.12 are not supported by the EPICS base
> 	• Debian Packages for RTEMS are no longer maintained
> 	• The intersection of the people using RTEMS and the ones using EPICS seems to be small and getting smaller, so with problems we are much on our own
> A possibility would be to use vxWorks again. Our current vxWorks version is very old and has to be updated. Problems here:
> 
> 	• MVME2100 boards do not seem to be supported by vxWorks 6
> 	• Possibly high costs for CPU licenses for vxWorks
> What are your experiences with this ? 
> Do you still use VME bus systems ?
> 
> Is there a future for RTEMS in EPICS control systems ?
> 
> Are there alternatives to RTEMS and vxWorks ?
> 
> Greetings,
> 
>   Goetz Pfeiffer

Attachment: smime.p7s
Description: S/MIME cryptographic signature


References:
Ideas / Suggestions for the future of VME-CPU Operating Systems Goetz Pfeiffer

Navigate by Date:
Prev: Re: Re: Action Button in Display Builder Kasemir, Kay
Next: PointGrey Firmware Mark Engbretson
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
Navigate by Thread:
Prev: Re: Ideas / Suggestions for the future of VME-CPU Operating Systems Andrew Johnson
Next: Re: Ideas / Suggestions for the future of VME-CPU Operating Systems Michael Davidsaver
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
ANJ, 20 Sep 2017 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·