Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017 Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
<== Date ==> <== Thread ==>

Subject: Re: Running CSS-4.5 from Eclipse Neon
From: "Kasemir, Kay" <kasemirk@ornl.gov>
To: Amien Crombie <acrombie@tlabs.ac.za>, EPICS Tech-Talk <tech-talk@aps.anl.gov>
Date: Wed, 30 Aug 2017 16:38:55 +0000
Hi:

You can't install into plain Eclipse.
You may be able to install into some other CS-Studio package, but there are too many variations.
Use the SNS product which already includes the display builder,
or the ESS product which does as well (though not sure where to get it),
or see 
https://github.com/ControlSystemStudio/org.csstudio.sns/tree/master/build ; for how the SNS product is built, and then do that to your product to include the display builder.

-Kay





From: Amien Crombie <acrombie@tlabs.ac.za>
Sent: Wednesday, August 30, 2017 12:28 PM
To: Kasemir, Kay; EPICS Tech-Talk
Subject: Running CSS-4.5 from Eclipse Neon
  
Hi Kay
I'm using your help in <<https://github.com/kasemir/org.csstudio.display.builder>> as a guideline in installing CSS inside Eclipse.

Yes, I'm trying to get CSS inside Eclipse (have installed Neon 4.6) 

Then added 

  CSS from here <<http://download.controlsystemstudio.org/updates/4.5>> and 
http://ics-web.sns.ornl.gov/css/display.builder 
Installed CSS Core ok but struggling to get the 'others' working...It goes into a install loop about 60% of the downloads and then get stuck.
In Eclipse-Neon I see the CSS in my preferences with all the settings one can use..
Regards
Amien



On 29/08/2017 19:09, Kasemir, Kay wrote:
 Hi:   I'm giving a small intro into my new CSS app to other CSS users this Friday. All of them are still using BOY/Opi with mostly Jython scripting. As my knowledge on Java is not great, I need to some advise on the following (if you have time):   The 'Builder' can convert most OPI files but the underlying scripts must be changed to the new 'Display' java classes.   Right. As much as possible and coding time allows, it reads existing displays, at least to the extend that I absolutely need this for operation of SNS beam lines where we have existing *.opi files. What doesn't convert: Scripts: They were always reserved for special cases, to do things that were impossible with EDM, MEDM, ... If you have to ask how to do a script, you probably shouldn't use them. If you still wanted to use them, you can now rewrite them.   Is there indication that other CSS users are also moving to the Builder ?   You'd have to ask them. ESS has been contributing to the display builder, they intend to use it. FRIB is interested.  Those that have many *.opi files will certainly need some time to update, that's OK. But starting a new project with BOY now, and continuing to add code to BOY at this time is a very bad idea: The BOY code entangles model, runtime and display. It's 99% on the UI thread and tightly depends on SWT, which in turn is dead.   Any way to add a genuine debugger in the newer CSS ? (or is this already possible?)   Not sure what you mean. You can attach jvisualvm to the running instance to monitor CPU, memory, .. You can start CSS from within Eclipse in debug mode and then single-step through everything.  Thanks, Kay  
   

Replies:
Re: Running CSS-4.5 from Eclipse Neon Amien Crombie
References:
CSS-4.5 : Display-Builder : getting widget's PV value Amien Crombie
Re: CSS-4.5 : Display-Builder : getting widget's PV value Kasemir, Kay
Re: CSS-4.5 : Display-Builder : getting widget's PV value Amien Crombie
Re: CSS-4.5 : Display-Builder : getting widget's PV value Kasemir, Kay
Re: CSS-4.5 : Display-Builder : getting widget's PV value Amien Crombie
Re: CSS-4.5 : Display-Builder : getting widget's PV value Kasemir, Kay
Running CSS-4.5 from Eclipse Neon Amien Crombie

Navigate by Date:
Prev: Running CSS-4.5 from Eclipse Neon Amien Crombie
Next: Re: Running CSS-4.5 from Eclipse Neon Amien Crombie
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
Navigate by Thread:
Prev: Running CSS-4.5 from Eclipse Neon Amien Crombie
Next: Re: Running CSS-4.5 from Eclipse Neon Amien Crombie
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
ANJ, 30 Aug 2017 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·