Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017 Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
<== Date ==> <== Thread ==>

Subject: XYgraph pv_name
From: Amien Crombie <acrombie@tlabs.ac.za>
To: EPICS Tech-Talk <tech-talk@aps.anl.gov>
Date: Wed, 2 Aug 2017 13:21:40 +0200

Hi


I have a script as follows:

link = display.getWidget("linko")
child = link.getChild("xgraph")    # get the xygraph on linko

# here I get the 2 PV's i passed to the script

val= PVUtil.getString(pvs[0])   # this PV is used to switch to the desired opi
dal= PVUtil.getString(pvs[1])   # this is the PV i need

if val=="1.0":
    child.setPropertyValue("pv_name", dal)   # here the correct PV is displayed
    child.setPropertyValue("title",dal)

else:

    # do nothing


So when I call the script, everything works except the xygraph displays no trace. If I do a "PV info" when CSS is running on the graph, it actually shows the graph values.

It looks like the xygraph is not updating the trace at all.

Amien




Replies:
Re: XYgraph pv_name Kasemir, Kay

Navigate by Date:
Prev: RE: EPICS Redundancy Penning, Joerg
Next: Magna MS power supply Pierrick M Hanlet
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
Navigate by Thread:
Prev: Re: Using CSS ViewParts in Eclipse 4 Kasemir, Kay
Next: Re: XYgraph pv_name Kasemir, Kay
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
ANJ, 02 Aug 2017 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·