Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017 Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
<== Date ==> <== Thread ==>

Subject: Re: jca question
From: Jeong Han Lee <citadel.lee@gmail.com>
To: tech-talk@aps.anl.gov
Date: Tue, 27 Jun 2017 16:02:35 +0200
Hi Liang yx,

If you would like to install jca because of the archiver appliance installation, you can ignore the installation of jca.

What you need is the EPICS base installation, and let the archiver appliance know where your EPICS base is.

  you should define LD_LIBRARY_PATH as well.

   Best,
   Han

On 06/23/2017 05:06 PM, 梁雅翔 wrote:
Hi all,
    I met some question when I install the channel archiver.
    I should install the caj first as the web said: http://slacmshankar.github.io/epicsarchiver_docs/details.html.
    The Download lind was broken, the Sourceforge link took me to "Java Channel Access", does JCA was CAJ ?
    then when I try to install JCA (Java Channel Access), I met the question.

my jca was put in /base/extension/src and jdk was installed.
Feora 23, linux86_64, base 3.1.12.5


Here is my output of ant:
********************************
[root@localhost config]# cd ..
[root@localhost jca2.1.2]# ant
Buildfile: /opt/epics/extensions/src/jca2.1.2/build.xml

build.core.java:
     [echo] Building core classes
    [javac] /opt/epics/extensions/src/jca2.1.2/build.xml:143: warning: 'includeantruntime' was not set, defaulting to build.sysclasspath=last; set to false for repeatable builds
    [javac] Compiling 112 source files to /opt/epics/extensions/src/jca2.1.2/O.core
    [javac] /opt/epics/extensions/src/jca2.1.2/src/core/gov/aps/jca/dbr/Severity.java:4: error: unmappable character for encoding UTF8
    [javac]  * Created on 15 d�cembre 2003, 09:45
    [javac]                   ^
    [javac] /opt/epics/extensions/src/jca2.1.2/src/core/gov/aps/jca/dbr/Status.java:4: error: unmappable character for encoding UTF8
    [javac]  * Created on 15 d�cembre 2003, 09:32
    [javac]                   ^
    [javac] 2 errors

BUILD FAILED
/opt/epics/extensions/src/jca2.1.2/build.xml:143: Compile failed; see the compiler error output for details.

Total time: 0 seconds



Thanks,
Liang yx


References:
jca question 梁雅翔

Navigate by Date:
Prev: Re: jca question Jeong Han Lee
Next: Area Detector and high performance NVME devices Mark S. Engbretson
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
Navigate by Thread:
Prev: Re: jca question Jeong Han Lee
Next: Re: Could you help us how we can compile an EPICS IOC with vxWorks6.8. Thanks! Andrew Johnson
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
ANJ, 27 Jun 2017 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·