Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017 Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
<== Date ==> <== Thread ==>

Subject: Re: Is there any support for EPICS for IronPython (or anyone working on it)?
From: "Hartman, Steven M." <hartmansm@ornl.gov>
To: EPICS Tech Talk <tech-talk@aps.anl.gov>
Cc: "Skorpenske, Harley David" <skorpenskehd@ornl.gov>
Date: Fri, 12 May 2017 18:44:45 +0000
In follow up to http://www.aps.anl.gov/epics/tech-talk/2016/msg01425.php from last August . . .

The MTS customer referenced was one of the beam lines here at SNS. They are interested in using the IronPython interface included with the new MTS load-frame software to pass parameters to our EPICS beam line control system using PyEpics. 

Harley (cc’d here but not on tech-talk) gave it a try . . .

>>> from epics import caget
>>> beampower = caget('RTBT_Diag:BCM25I:Power60')
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "C:\Python27\Lib\site-packages\epics\__init__.py", line 81, in caget
  File "C:\Python27\Lib\site-packages\epics\pv.py", line 39, in get_pv
  File "C:\Python27\Lib\site-packages\epics\ca.py", line 359, in wrapper
  File "C:\Python27\Lib\site-packages\epics\ca.py", line 239, in initialize_libca
AttributeError: 'ArrayType' object has no attribute 'in_dll'

>>> beampower = caget('RTBT_Diag:BCM25I:Power60')
cannot connect to RTBT_Diag:BCM25I:Power60
>>>


The first call to pyepics from IronPython always gives the AttributeError; all subsequent calls give “cannot connect”. 

Regular C Python 2.7 was used to install PyEpics using the installer exe. On the same host, it can successfully connect and read the same PV so not likely to be a network or access permission issue.  

Tested with . . .
IronPython 2.7.7 (2.7.7.0) on .NET 4.0.30319.42000 
32-bit and 64-bit


Any suggestions?

Thanks,
-- 
Steven Hartman
hartmansm@ornl.gov






Replies:
Re: Is there any support for EPICS for IronPython (or anyone working on it)? Matt Newville

Navigate by Date:
Prev: OPC UA EPICS device support license Thomas, Patrick
Next: Re: Is there any support for EPICS for IronPython (or anyone working on it)? Matt Newville
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
Navigate by Thread:
Prev: Re: OPC UA EPICS device support license Jack
Next: Re: Is there any support for EPICS for IronPython (or anyone working on it)? Matt Newville
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
ANJ, 18 May 2017 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·