Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017 Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
<== Date ==> <== Thread ==>

Subject: S7plc driver - PV block receiving problems
From: Gianluca Borgese <gianlucaborgese@gmail.com>
To: tech-talk@aps.anl.gov
Date: Sat, 28 Jan 2017 12:12:32 +0100
Dear All, I'm using the s7plc driver to monitor and control an RF modulator which has a PLC sending a 253byte data array and receiving a 16byte data array to/from my IOC. I did some test using the PLC server emulator (server.tcl) which was into the s7plc folder and all is nice and working right! I obtain the right process variable (PV) values I expect!!! But when I connect my IOC to the real PLC I have problems with the PVs. The PV values sometimes are correct and often wrong! Do you have any idea about the possible causes? Thanks in advance. Regards, Gianluca

Replies:
Re: S7plc driver - PV block receiving problems Dirk Zimoch

Navigate by Date:
Prev: Spring EPICS meeting in May at KURRI, Osaka, Japan 上窪田@KEKTokai
Next: Sequencer and Visual Studio 2015 express freddie.akeroyd
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
Navigate by Thread:
Prev: Spring EPICS meeting in May at KURRI, Osaka, Japan 上窪田@KEKTokai
Next: Re: S7plc driver - PV block receiving problems Dirk Zimoch
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
ANJ, 14 Feb 2017 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·