Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017 Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
<== Date ==> <== Thread ==>

Subject: Re: problem connecting serial device with moxa 5150A
From: Luca Cavalli <LCavalli@cgspace.it>
To: "tech-talk@aps.anl.gov" <tech-talk@aps.anl.gov>
Date: Tue, 24 Jan 2017 14:09:08 +0000
Hi Mark,

is the routing table correctly configured?

Cheers,

Luca


On Tue, 2017-01-24 at 13:33 +0000, Mark Rivers wrote:
> I'm trying to help Sunny to connect from Linux to a serial port on a Moxa
> box.  It is not working, and I am stumped, so any ideas are welcome.
>
> From Windows he can telnet to it:
>
> > when I telnet from windows
> > telnet 192.168.127.254 4001
> > It prompts a blank screen and for other IP or ports like 192.168.127.254
> > 5064, 192.168.127.34 4732 etc. it simply says host not available so I think
> > port 4001 should be good.
>
> When he connects it to Linux he can ping it:
>
> ping 192.168.127.254
> PING 192.168.127.254 (192.168.127.254) 56(84) bytes of data.
> 64 bytes from 192.168.127.254<http://192.168.127.254>: icmp_seq=1 ttl=255
> time=1.69 ms
> 64 bytes from 192.168.127.254<http://192.168.127.254>: icmp_seq=2 ttl=255
> time=0.797 ms
> 64 bytes from 192.168.127.254<http://192.168.127.254>: icmp_seq=3 ttl=255
> time=0.753 ms
>
> ifconfig looks OK:
> eth0      Link encap:Ethernet  HWaddr D8:CB:8A:9C:61:96
>           inet addr:192.168.127.0  Bcast:192.168.127.255  Mask:255.255.255.0
>           inet6 addr: fe80::dacb:8aff:fe9c:6196/64 Scope:Link
>           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>           RX packets:16 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:63 errors:0 dropped:0 overruns:0 carrier:0
>           collisions:0 txqueuelen:1000
>           RX bytes:1454 (1.4 Kb)  TX bytes:10799 (10.5 Kb)
>
> arp looks good:
> sbin/arp
>
> Address                  HWtype  HWaddress           Flags
> Mask            Iface
> 10.128.0.254             ether   00:00:5e:00:01:83   C                     eth
> 1
> 10.128.0.99              ether   00:04:96:6d:67:7f   C                     eth
> 1
> 10.128.0.253             ether   00:04:96:15:5e:70   C                     eth
> 1
> 10.128.0.238             ether   00:04:96:27:50:63   C                     eth
> 1
> 10.128.0.244             ether   00:04:96:34:ea:f2   C                     eth
> 1
> 10.128.0.252             ether   00:04:96:28:24:ce   C                     eth
> 1
> 10.128.0.237             ether   00:04:96:51:a8:8b   C                     eth
> 1
> 192.168.127.254          ether   00:90:e8:4e:6e:4e   C                     eth
> 0
> 10.128.0.251             ether   00:04:96:16:c7:50   C                     eth
> 1
> 10.128.0.249             ether   00:04:96:05:7a:13   C                     eth
> 1
> 10.128.0.247             ether   00:04:96:36:54:da   C                     eth
> 1
> 10.128.0.246             ether   00:04:96:21:d6:10   C                     eth
> 1
>
> The firewall is disabled:
>  systemctl status SuSEfirewall2.service
>
> SuSEfirewall2 phase 2
>    Loaded: loaded (/usr/lib/systemd/system/SuSEfirewall2.service; disabled)
>    Active: inactive (dead)
>
> But when he tries to telnet from the Linux box it times out:
>
> telnet 192.168.127.254 4001
> Trying 192.168.127.254...
> telnet: connect to address 192.168.127.254<http://192.168.127.254>: Connection
> timed out
>
> Any ideas what could be causing this?
>
> Thanks,
> Mark
>
>
>


________________________________

<< Le informazioni contenute in questo messaggio di posta elettronica e relativi allegati sono riservate e confidenziali e ne è vietata la diffusione in qualunque modo eseguita. Qualora Lei non fosse la persona a cui il presente messaggio è destinato, La invitiamo ad eliminarlo e a darcene gentile comunicazione. Quanto precede ai fini del rispetto delle Legge 675/96 e del Decreto Legislativo 30/06/2003 n.196, sulla tutela dei dati personali >>

<< This e-mail is confidential and may well also be legally privileged. If you have received it in error, you are on notice of its status. Please notify us immediately by reply e-mail and then delete this message from your system. Please do not copy it or use it for any purposes, or disclose its contents to any other person: to do so could be a breach of confidence. Thank you for your co-operation. Please contact our IT Helpdesk on +3902380481 or email it@cgspace.it if you need assistance >>



Replies:
Re: problem connecting serial device with moxa 5150A haquin
References:
problem connecting serial device with moxa 5150A Sunny Badkul
RE: problem connecting serial device with moxa 5150A Mark Rivers
RE: problem connecting serial device with moxa 5150A Mark Rivers

Navigate by Date:
Prev: Re: problem connecting serial device with moxa 5150A Torsten Bögershausen
Next: Re: problem connecting serial device with moxa 5150A haquin
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
Navigate by Thread:
Prev: Re: problem connecting serial device with moxa 5150A Torsten Bögershausen
Next: Re: problem connecting serial device with moxa 5150A haquin
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
ANJ, 14 Feb 2017 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·