Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017 Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
<== Date ==> <== Thread ==>

Subject: synApps_5_8 build error
From: "Abdalla Ahmad" <abdalla.ahmad@sesame.org.jo>
To: "tech-talk@aps.anl.gov" <tech-talk@aps.anl.gov>
Date: Sun, 8 Jan 2017 06:26:06 +0000

Hi

 

I downloaded the mentioned version of synApps and I modified SUPPORT and EPICS_BASE in configure/RELEASE file as:

 

SUPPORT=$(SYNAPPS_SUPPORT)

EPICS_BASE=$(ENV_EPICS_BASE)

 

These variables are already defined in .bashrc and exported. The list of modules for our site is

 

Asyn

Allen_Bradlley

Autosave

Busy (Added to resolve a similar error at compiling asyn )

Calc

IP

IPAC

Motor

SNCSEQ

SSCAN

STREAM

 

Executing 'make release' then make gives the following:

 

Definition of SNCSEQ conflicts with SUPPORT support.

In this application a RELEASE file defines

                SNCSEQ = /home/control/epics/support/synApps_5_8/support/seq-2-2-1

but SUPPORT at /home/control/epics/support/synApps_5_8/support defines

                SNCSEQ = /seq-2-2-1

Definition of EPICS_BASE conflicts with SUPPORT support.

In this application a RELEASE file defines

                EPICS_BASE = /home/control/epics/base-3.14.12.3

but SUPPORT at /home/control/epics/support/synApps_5_8/support defines

                EPICS_BASE =

Definition of SUPPORT conflicts with SUPPORT support.

In this application a RELEASE file defines

                SUPPORT = /home/control/epics/support/synApps_5_8/support

but SUPPORT at /home/control/epics/support/synApps_5_8/support defines

                SUPPORT =

 

I have no clue of where these wrong definitions are. I thought of giving hard coded paths for the aforementioned variables instead of env ones and the build works fine. I believe on synApps 5.6 we did not face that error.

 

Best Regards,

 

Abdalla Ahmad

Control Engineer

SESAME

Allan, Jordan.

Tel: (+962-5) 3511348 , ext. 265

Fax: (+962-5) 3511423

Mob: (+962-7)88183296

www.sesame.org.jo

 


Replies:
RE: synApps_5_8 build error Mark Rivers

Navigate by Date:
Prev: The limit of height property of Grouping Container of CSS widget 吴煊
Next: RE: synApps_5_8 build error Mark Rivers
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
Navigate by Thread:
Prev: The limit of height property of Grouping Container of CSS widget 吴煊
Next: RE: synApps_5_8 build error Mark Rivers
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
ANJ, 14 Feb 2017 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·