Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017 Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
<== Date ==> <== Thread ==>

Subject: Re: Acromag IP230A/231 support
From: Bruce Hill <bhill@slac.stanford.edu>
To: <tech-talk@aps.anl.gov>
Date: Wed, 4 Jan 2017 14:47:58 -0800

Hi Ron,

You can download a tarball for our latest IP231 module here:

http://www.slac.stanford.edu/~bhill/epics-pcds/modules-R3.14.12/ip231/ip231-2.2.3-1.4.1.tgz

You may also need our version of ipac to go with it.

http://www.slac.stanford.edu/~bhill/epics-pcds/modules-R3.14.12/ipac/ipac-3.0.0-1.1.4.tgz

I'm not sure how close these are to the ip230 and ipac support that Kevin posted.   The versions above are derived from IP module support that Sheng Peng did for our accelerator group back in 2007.   The ipac module in particular will be difficult to merge with what's on github as it includes a number of features that Richard Dabney implemented for our photon controls group in 2013 including support for running IP cards on a APCI8650 card under linux.   I looked briefly into merging our ipac w/ the github.com/epics-modules/ipac version and found they had diverged quite a bit.

We're in the process of converting our version control to git but haven't gotten to the IP modules yet.   We also have ip330, ip440, and ip445 support.  Hopefully we can start moving more of these to github over the next year and try to resolve some of the conflicts w/ the different ipac module versions.

Cheers,

- Bruce Hill


On 12/21/2016 03:30 PM, Kevin Tsubota wrote:

I’ve just placed a tarball with all the IP module drivers we have here at Keck Observatory:

-          IP230

-          IP330

-          IP480

-          IP501

-          IPDigital24

-          IPDriver40

-          IP carrier

To our ftp site: ftp://ftp.keck.hawaii.edu/outgoing/epics/drivers/

 

Feel free to download and if you have any issues let me know.

 

Also, please update the contact as me for these drivers as well.

 

Thank you,

Kevin Tsubota

ktsubota@keck.hawaii.edu

 

 

 

From: tech-talk-bounces@aps.anl.gov [mailto:tech-talk-bounces@aps.anl.gov] On Behalf Of Ron Sluiter
Sent: Wednesday, December 21, 2016 12:37 PM
To: EPICS
Subject: Acromag IP230A/231 support

 

The EPICS "Hardware Support: by Manufacturer" for Acromag list the IP230 D/A module with Len Reder (JPL) as the contact. Unfortunately, Len Reder left the EPICS collaboration long ago.

I am looking to either find or write support for the Acromag IP231: Analog Output Module. The IP230 support software may be close enough so that I do not have to start from nothing. Can someone send me, or tell me where I can find, Len's IP230 EPICS device/driver support?

Ron


-- 
Bruce Hill
Member Technical Staff
SLAC National Accelerator Lab
2575 Sand Hill Road M/S 10
Menlo Park, CA  94025

Navigate by Date:
Prev: Re: Default value to field SCAN Andrew Johnson
Next: synApps_5_6 build error under Scientific Linux 7 64-bit Abdalla Ahmad
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
Navigate by Thread:
Prev: Re: BACnet driver writing values to a device Kyle Lanclos
Next: synApps_5_6 build error under Scientific Linux 7 64-bit Abdalla Ahmad
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  <2017
ANJ, 14 Feb 2017 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·