Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017 
<== Date ==> <== Thread ==>

Subject: Re: 3.14 v.s. 3.15 vs. v4
From: Pete Jemian <jemian@anl.gov>
To: tech-talk@aps.anl.gov
Date: Wed, 21 Nov 2012 15:56:41 -0600

Jack:

You will hear from the accelerator folks on the details. The overview is that some systems remain on legacy versions of EPICS base because they depend on reliable, yet legacy hardware. With the impressive uptime that the accelerator is run and the number of IOCs in deployment, one can appreciate that a conservative approach to upgrades has been adopted.

The X-ray beam lines (who are direct beneficiaries of the efforts of the EPICS core team) that run EPICS (200 VxWorks IOCs, ca. 100 Linux IOCs, perhaps a few RTEMS IOCs) are all on 3.14 versions. It is much easier to apply upgrades at beam lines since they each independently and can be upgraded on an individual basis.

Pete

On 11/21/2012 2:54 PM, Jack Smith wrote:
Hi Andrew,

Thanks for pointing out the new features in the Base 3.15.

I'm very surprised by the chart "Accelerator IOC EPICS Versions" in
your presentation: ~60% IOCs were using aged version 3.13 in March,
2011 and 25% in Sept. 2012. I always think that APS is the pioneer in
the EPICS base. But after seeing this chart, I think that APS is
pioneering in the base development rather than the deployment. Could
anyone share your experience and opinion why it is so difficult to
upgrade the legacy to the up-to-date?

Thanks,

Jack

--
----------------------------------------------------------
Pete R. Jemian, Ph.D.                <jemian@anl.gov>
Beam line Controls and Data Acquisition, Group Leader
Advanced Photon Source,   Argonne National Laboratory
Argonne, IL  60439                   630 - 252 - 3189
-----------------------------------------------------------
   Education is the one thing for which people
      are willing to pay yet not receive.
-----------------------------------------------------------



References:
3.14 v.s. 3.15 vs. v4 Jack Smith
Re: 3.14 v.s. 3.15 vs. v4 Andrew Johnson
Re: 3.14 v.s. 3.15 vs. v4 Jack Smith

Navigate by Date:
Prev: Re: 3.14 v.s. 3.15 vs. v4 Jack Smith
Next: Re: caRepeater object code not cross-compiled in R3.14.12.2 Dirk Zimoch
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017 
Navigate by Thread:
Prev: Re: 3.14 v.s. 3.15 vs. v4 Jack Smith
Next: 3.14 v.s. 3.15 vs. v4 Richard Farnsworth
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017 
ANJ, 18 Nov 2013 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·