Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017 
<== Date ==> <== Thread ==>

Subject: burtrb failing on local LAN, but not through gateway
From: Keith Thorne <kthorne@ligo-la.caltech.edu>
To: tech-talk@aps.anl.gov
Date: Wed, 17 Oct 2012 11:49:57 -0500
We use the burt extension heavily for backup and restoration of settings on Linux-based IOCs.  
We are seeing the burtrb calls fail when invoked for a large list (~14,000) channels when run on the same LAN as the computer with the IOC.  The application successfully completes the ca_search_and_connect calls for all channels, but only gets successful connections for a few hundred channels.  Interestingly, the same burtrb call works just fine when run from a computer on a different LAN where an EPICS gateway is used to provide access. 

We are using Ubuntu 10.04 (64-bit) with EPICS 3.14.2 on the client.

We tried increasing the number of retries, but all that does is increase the wait time (in 1 second increments) for checking that all connections are made.  This does not work.

The Burt extension (as well as the casr extension) have not be updated for 3.14.x.  Are there suggestions for an alternate snapshot/restore tool that is being updated?

Thanks
	Keith Thorne
	LIGO Livingston Observatory

Replies:
RE: burtrb failing on local LAN, but not through gateway Hill, Jeff

Navigate by Date:
Prev: RE: gpu integration into epics Dalesio, Leo
Next: RE: burtrb failing on local LAN, but not through gateway Hill, Jeff
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017 
Navigate by Thread:
Prev: Re: Immediately reprocess a record [SEC=UNCLASSIFIED] Tim Mooney
Next: RE: burtrb failing on local LAN, but not through gateway Hill, Jeff
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017 
ANJ, 18 Nov 2013 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·