Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017 
<== Date ==> <== Thread ==>

Subject: EPICS 3.15.0 incompatible make rules
From: Dirk Zimoch <dirk.zimoch@psi.ch>
To: EPICS <tech-talk@aps.anl.gov>
Date: Fri, 05 Oct 2012 15:48:03 +0200
Hi all,

When I try to build an application including SNL, I get the following error message: /usr/local/epics/base-3.15.0/../seq/configure/RULES_BUILD:67: *** target file `clean' has both : and :: entries. Stop.

The problem: The seq RULES_BUILD uses "clean::" and so does EPICS 3.14. But EPICS 3.15 changed the clean rule to "clean:" (with only one :).

This problem may happen with many more extension packages. So can we stay compatible in 3.15 and use :: rules where 3.14 did?

Dirk



Replies:
Re: EPICS 3.15.0 incompatible make rules Ron Sluiter

Navigate by Date:
Prev: Re: waveform EDM widget Kasemir, Kay
Next: Re: Triggered autosave on exit Tim Mooney
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017 
Navigate by Thread:
Prev: Re: waveform EDM widget Hinko Kocevar
Next: Re: EPICS 3.15.0 incompatible make rules Ron Sluiter
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  2015  2016  2017 
ANJ, 18 Nov 2013 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·