g+
g+ Communities
Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014 
<== Date ==> <== Thread ==>

Subject: Re: edm and other extensions on 64-bit SL machines
From: Pierrick M Hanlet <hanlet@fnal.gov>
To: Janet Anderson <jba@aps.anl.gov>, "tech-talk@aps.anl.gov" <tech-talk@aps.anl.gov>
Date: Wed, 5 Sep 2012 00:22:52 +0000
Excellent!
Mille grazie.
Pierrick

Sent from my Verizon Wireless Phone

----- Reply message -----
From: "Janet Anderson" <jba@aps.anl.gov>
To: "tech-talk@aps.anl.gov" <tech-talk@aps.anl.gov>
Subject: edm and other extensions on 64-bit SL machines
Date: Tue, Sep 4, 2012 11:56



Hi Pierrick,

I put a new version of the extensionsTop tar file on the EPICS
extensions/configure/ web page. This version has the 64 bit paths.

Janet


On 08/31/2012 05:49 PM, Pierrick Hanlet wrote:
> Hi Andrew,
> This appears to be the problem.
> There is nothing in the file other than the -include
> $(TOP)/configure/os/CONFIG_SITE.linux-x86.linux-x86;
> so it points to the the 32-bit varieties.
> Thank you,
> Pierrick
>
> On 08/31/2012 05:45 PM, Andrew Johnson wrote:
>> Hi Pierrick,
>>
>> On 2012-08-31 Pierrick Hanlet wrote:
>>> Both edm and alh require libXm (and perhaps others of that suite).  Each
>>> fail to build with
>>> the error:
>>>    No rule to make target `/usr/lib/libXm.a'.
>>> This tells me that it searched and expects to find the library in
>>> /usr/lib.  If I understand things
>>> correctly, should it not be searching in /usr/lib64 since that is where
>>> the libraries reside?
>> Take a look at the file
>>    extensions/configure/os/CONFIG_SITE.linux-x86_64.linux-x86_64
>> which should set those paths for you.
>>
>> - Andrew
>
> --
> "Whether you think you can or think you can't, either way, you are correct" --
> Henry Ford
> _______________________________________________________________
> *Pierrick Hanlet*
> IIT/Fermilab
> +1-630-840-5555 (FNAL)
> +1-312-567-5745 (IIT)
> +1-630-697-8758/+44-79-48-860-197 (US/UK mobile)

References:
edm and other extensions on 64-bit SL machines Pierrick Hanlet
Re: edm and other extensions on 64-bit SL machines Jennings Guy
Re: edm and other extensions on 64-bit SL machines Pierrick Hanlet
Re: edm and other extensions on 64-bit SL machines Andrew Johnson
Re: edm and other extensions on 64-bit SL machines Pierrick Hanlet
Re: edm and other extensions on 64-bit SL machines Janet Anderson

Navigate by Date:
Prev: Re: edm and other extensions on 64-bit SL machines Janet Anderson
Next: Problem with medmfonts.ali running under Ubuntu 1204 Ivan Kohler
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014 
Navigate by Thread:
Prev: Re: edm and other extensions on 64-bit SL machines Janet Anderson
Next: Re: edm and other extensions on 64-bit SL machines J. Lewis Muir
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014 
ANJ, 18 Nov 2013 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICSv4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·