g+
g+ Communities
Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014 
<== Date ==> <== Thread ==>

Subject: Re: EDM X Error on Linux
From: Lucas Russo <lerwys@gmail.com>
To: Jason Abernathy <jabrnthy@uvic.ca>
Cc: tech-talk@aps.anl.gov
Date: Mon, 27 Aug 2012 09:32:31 -0300
Hello everyone again,

By following the suggestion from Jason Abernathy:

From Jason Abernathy:

I have found that running EDM will yield the error


Error: No realize class procedure defined

after an (apparantly) successful build on an Ubuntu 11.10 system.

This can be solved modifying the edmMain/Makefile

    edm_LIBS_Linux += Xm Xmu Xt Xp Xtst X11
    USR_LDFLAGS_Linux += -Wl,--no-as-needed<--- add this line
    edm_SYS_LIBS_Linux += pthread dl

I managed to get EDM working (or so it seems).

I noticed that the EDM compiled with the makefile modification has six more dynamic links, namely:

> ldd $EDM

libXtst.so.6 => /usr/lib/x86_64-linux-gnu/libXtst.so.6 (0x00007f174e552000)
libca.so.3.14 => /opt/epics/base/lib/linux-x86_64/libca.so.3.14 (0x00007f174dfb8000)
libCom.so.3.14 => /opt/epics/base/lib/linux-x86_64/libCom.so.3.14 (0x00007f174dd5f000)
libreadline.so.6 => /lib/x86_64-linux-gnu/libreadline.so.6 (0x00007f174d6fb000)
librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f174d4f2000)
libtinfo.so.5 => /lib/x86_64-linux-gnu/libtinfo.so.5 (0x00007f174ba91000)

If I may ask, how did you realize that the option --no-as-needed could solve the problem?
Perhaps it was noted that some important libraries weren't linked against? If so, why didn't
they get referenced in order to be included by the linker?

Thank you all once again!

Best Regards,

Lucas

On Sat, Aug 25, 2012 at 3:59 PM, Lucas Russo <lerwys@gmail.com> wrote:
Hello Jason and John,

Thank you very much for the responses.

I'm going to try to rebuild the EDM by modifying the Makefile as suggested first.
If, however, I'm unsuccessful the PPA from Jason seems a good source of epics related
packages.

Thanks again!

Lucas


On Sat, Aug 25, 2012 at 3:06 PM, Jason Abernathy <jabrnthy@uvic.ca> wrote:
Hello Lucas,

You can also installed EDM on Ubuntu via my Debian personal package archive for EPICS:
https://launchpad.net/~j-abernathy/+archive/epics-ppa

p.s. does anyone know how to respond to a single message from the daily Tech-talk summary?



References:
Re: EDM X Error on Linux Jason Abernathy
Re: EDM X Error on Linux Lucas Russo

Navigate by Date:
Prev: Re: EDM X Error on Linux Lucas Russo
Next: Re: Creating INLINK/OUTLINK in record support Tim Mooney
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014 
Navigate by Thread:
Prev: Re: EDM X Error on Linux Lucas Russo
Next: Fwd: EDM X Error on Linux Lucas Russo
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014 
ANJ, 18 Nov 2013 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICSv4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·