g+
g+ Communities
Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014 
<== Date ==> <== Thread ==>

Subject: Re: EPICS Base version 3.15.0.1 released
From: Dirk Zimoch <dirk.zimoch@psi.ch>
To: Andrew Johnson <anj@aps.anl.gov>
Cc: EPICS tech-talk <tech-talk@aps.anl.gov>
Date: Mon, 13 Aug 2012 10:12:13 +0200
Andrew Johnson wrote:
Announcing the first developer release in the Base 3.15 series, version 3.15.0.1 is now available for download and testing. Many new features have been incorporated into the code that have been in development since 2008 and were contributed by users from many different sites. Some of the changes have not even been mentioned in the Release Notes yet, but many have. Please read the release notes to get some idea what's new. Some updates were covered in the Application Developers Guide instead (or even as well), although the changes in that document might be a bit hard to spot.

Documentation and downloads available at
    http://www.aps.anl.gov/epics/base/R3-15/0.php

Thanks to everyone who has worked on this over the last few years (and please consider writing some documentation for your contribution, it's not much use it nobody knows how to use it!).

Note: This release should not be used for operational systems, it could blow holes in your beam pipe (or insert empty beer-cans into them), quench your superconducting magnets, or adjust all your undulator gaps to zero. Actually we don't guarantee that our regular releases won't do those things by mistake either, but this release contains new code that has not been significantly tested.

- Andrew

Older Linux versions still require ncurses in addition to readline, otherwise linking fails with undefined references.

Is there a way to automatically find out which Linux/Unix version requires curses or ncurses in addition to readline?

Is it possible to prompt the innocent user with a helpful error message like

Edit COMMANDLINE_LIBRARY variable in configure/CONFIG_SITE.Common.$(T_A)

instead of

/usr/lib/libreadline.so.5: undefined reference to `PC'
/usr/lib/libreadline.so.5: undefined reference to `tgetflag'
/usr/lib/libreadline.so.5: undefined reference to `tgetent'
/usr/lib/libreadline.so.5: undefined reference to `UP'
/usr/lib/libreadline.so.5: undefined reference to `tputs'
/usr/lib/libreadline.so.5: undefined reference to `tgoto'
/usr/lib/libreadline.so.5: undefined reference to `tgetnum'
/usr/lib/libreadline.so.5: undefined reference to `BC'

when linking iocLogServer?

BTW: Why does iocLogServer need readline? Maybe some library dependencies need to be cleaned up.

Dirk




References:
EPICS Base version 3.15.0.1 released Andrew Johnson

Navigate by Date:
Prev: Re: EPICS Base version 3.15.0.1 released Martin Konrad
Next: Re: EPICS Base version 3.15.0.1 released Dirk Zimoch
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014 
Navigate by Thread:
Prev: Re: EPICS Base version 3.15.0.1 released Andrew Johnson
Next: Re: EPICS Base version 3.15.0.1 released Dirk Zimoch
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014 
ANJ, 18 Nov 2013 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICSv4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·