g+
g+ Communities
Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014 
<== Date ==> <== Thread ==>

Subject: casStrmClient.cc error: invalid channel identifier
From: Emma Shepherd <Emma.Shepherd@synchrotron.org.au>
To: "tech-talk@aps.anl.gov" <tech-talk@aps.anl.gov>
Cc: Emmanuel Vettoor <Emmanuel.Vettoor@synchrotron.org.au>
Date: Mon, 2 Apr 2012 11:28:43 +1000
Hi,

I'm trying to track down the cause of an intermittent IOC crash, and came across launchpad bug 730720 which seems to be related (although in our case it doesn't involve CAJ clients).

Our symptoms are that when an IOC is rebooted, another IOC that has CA links to PVs served by that IOC through a gateway dies.  I believe that this happens on reboot of several different IOCs, not just one in particular.

We get the following error messages in the gateway log:


<snip>
Mar 18 07:09:11 Warning: Virtual circuit disconnect SR00IOC10.accelerator.synchrotron.org.au:5064 
CAS Request: ics on sr05id01ioc01: cmd=2 cid=31 typ=0 cnt=1 psz=0 avail=101
CAS: 
Mar 18 07:09:19 !!! Errlog message received (message is above)
bad resource id in "../../../../src/cas/generic/casStrmClient.cc" at line 1810

Mar 18 07:09:19 !!! Errlog message received (message is above)
filename="../../../../src/cas/generic/st/casStreamOS.cc" line number=582
Bad resource identifier - unexpected problem with client's input - forcing disconnect

Mar 18 07:09:19 !!! Errlog message received (message is above)
</snip>


And the following message in the IOC that subsequently dies:


<snip>
CA.Client.Exception...............................................
    Error: "Invalid channel identifier"
    Context: "host=10.114.10.246:5064 ctx=Bad Resource ID=31 detected at ../../../../src/cas/generic/casStrmClient.cc.1810"
    Current Time: Sun Mar 18 2012 07:09:19.697135000
</snip>

A reboot of the IOC is enough to fix it, the gateway itself doesn't need to be restarted.

We are using Gateway Version 2.0.3.0 and EPICS base 3.14.9 running on CentOS 4.4.  Has anybody been looking into this issue yet?

Thanks,
Emma


<br>This message and any attachments may contain proprietary or confidential information. If you are not the intended recipient or you received the message in error, you must not use, copy or distribute the message. Please notify the sender immediately and destroy the original message. Thank you.

Replies:
RE: casStrmClient.cc error: invalid channel identifier Emma Shepherd
Re: casStrmClient.cc error: invalid channel identifier Andrew Johnson

Navigate by Date:
Prev: RE: Fiber Optic Switches Bryce Karnaghan
Next: RE: casStrmClient.cc error: invalid channel identifier Emma Shepherd
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014 
Navigate by Thread:
Prev: Re: StripTool and History Kasemir, Kay
Next: RE: casStrmClient.cc error: invalid channel identifier Emma Shepherd
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  2010  2011  <20122013  2014 
ANJ, 18 Nov 2013 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICSv4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·