Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  <20102011  2012  2013  2014  2015  2016  2017  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  <20102011  2012  2013  2014  2015  2016  2017 
<== Date ==> <== Thread ==>

Subject: ellFree vs ellFree2
From: Dirk Zimoch <dirk.zimoch@psi.ch>
To: EPICS <tech-talk@aps.anl.gov>
Date: Tue, 22 Jun 2010 16:05:51 +0200
Hi gurus,

I just found that the function ellFree does not exist any more in EPICS base 3.14.11. It has been replaced with a macro and the function ellFree2. Unfortunately, that means that binaries compiled with 3.14.8 cannot run with a 3.14.11 library. Until 3.14.8, the libraries were always backward compatible. (Binary compatible!, not only source code compatible).

I looked for a good reason for this change but I could not find any code in base that calls ellFree2 (expect for the test code). Can someone please tell me what was the reason for this incompatible change?

Dirk
Replies:
Re: ellFree vs ellFree2 Andrew Johnson

Navigate by Date:
Prev: Problems configuring 4 IK320 cards Linda.Pratt
Next: Re: ellFree vs ellFree2 Andrew Johnson
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  <20102011  2012  2013  2014  2015  2016  2017 
Navigate by Thread:
Prev: RE: Problems configuring 4 IK320 cards Linda.Pratt
Next: Re: ellFree vs ellFree2 Andrew Johnson
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  <20102011  2012  2013  2014  2015  2016  2017 
ANJ, 02 Sep 2010 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·