Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  <20102011  2012  2013  2014  2015  2016  2017  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  <20102011  2012  2013  2014  2015  2016  2017 
<== Date ==> <== Thread ==>

Subject: RE: No monitor refresh
From: "Jeff Hill" <johill@lanl.gov>
To: "'Hinko Kocevar'" <hinko.kocevar@i-tech.si>, "'EPICS Tech-Talk'" <tech-talk@aps.anl.gov>
Date: Tue, 11 May 2010 08:45:32 -0600
Hello Hinko,

You mention that a caput updates the value in the IOC but the subscription update does not arrive or is late arriving. That might happen if 100% of the IOC's CPU is being consumed by threads running at higher priorities than the CA server. What type of record and field is the camonitor attached to?

Jeff
______________________________________________________
Jeffrey O. Hill           Email        johill@lanl.gov
LANL MS H820              Voice        505 665 1831
Los Alamos NM 87545 USA   FAX          505 665 5107

Message content: TSPA


> -----Original Message-----
> From: tech-talk-bounces@aps.anl.gov [mailto:tech-talk-
> bounces@aps.anl.gov] On Behalf Of Hinko Kocevar
> Sent: Tuesday, May 11, 2010 4:27 AM
> To: EPICS Tech-Talk
> Subject: No monitor refresh
> 
> Hi all,
> 
> I'm experiencing some strange behavior when using camonitor against an
> EPICS IOC.
> 
> For some reason a CA_PROTO_EVENT_ADD response from IOC to CA client does
> not arrive, or arrives several minutes later after the PV value has
> changed. Note that first CA_PROTO_EVENT_ADD response is seen always,
> only latter CA_PROTO_EVENT_ADD responses do not arrive (or arrive late)?!
> This behavior is not seen always - sometimes the IOC would promptly
> respond with CA_PROTO_EVENT_ADD response when needed.
> 
> I can see the CA_PROTO_ECHO requests/responses fine on the same
> camonitor channel link, only CA_PROTO_EVENT_ADD response is not seen.
> 
> Inspecting the IOC I can see that the value did change (on lower levels)
> and caput response is also valid - updated with new value.
> 
> I've ruled out the network problems, since the issue is raised even when
> using cross-over cable to communicate with the IOC. Actually even I
> update the value in the IOC shell, the camonitor is not refreshed!!
> 
> 
> 
> Has someone experienced something similar?
> Are there some conditions that need to fulfilled in order for IOC to
> send a subsequent CA_PROTO_EVENT_ADD response(s)?
> 
> 
> 
> TIA & HAND,
> Hinko
> 
> --
> Hinko Kocevar
> Technical support software engineer
> Instrumentation Technologies
> Velika pot 22, SI-5250 Solkan - Slovenia
> T:+386 5 3352600, F:+386 5 3352601
> mailto: hinko.kocevar@i-tech.si
> 
> http://www.i-tech.si - When your users demand stability
> 
> The information transmitted is intended solely for the addressee and may
> contain confidential and/or privileged information. Any review,
> retention,
> disclosure or other use by persons other than the intended recipient is
> prohibited. If you received this in error, please notify the sender and
> delete all copies.



Replies:
Re: No monitor refresh Hinko Kocevar
References:
No monitor refresh Hinko Kocevar

Navigate by Date:
Prev: Re: No monitor refresh Hinko Kocevar
Next: Re: No monitor refresh Ralph Lange
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  <20102011  2012  2013  2014  2015  2016  2017 
Navigate by Thread:
Prev: Re: No monitor refresh Hinko Kocevar
Next: Re: No monitor refresh Hinko Kocevar
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  2008  2009  <20102011  2012  2013  2014  2015  2016  2017 
ANJ, 02 Sep 2010 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·