g+
g+ Communities
Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  <20082009  2010  2011  2012  2013  2014  Index 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  <20082009  2010  2011  2012  2013  2014 
<== Date ==> <== Thread ==>

Subject: problem in running application of PSM6003
From: zhangdemin99 <zhangdemin99@163.com>
To: tech-talk@aps.anl.gov
Date: Fri, 4 Jan 2008 15:55:04 +0800 (CST)
Dear all,
  Thanks Norum for your attention, and now it works well.But
there is another problem when running appilication which I have
built for the NI power supply connected to the PC with PCI-GPIB
board.I have built the driver NI-4882 package for the board.
In the st.cmd file,I only add GpibBoardDriverConfig("L0",1,0,3,0),
but it says this command not found. Is it linux-gpib not built well?
I have built linux-gpib like this:
(1)cp /boot/config-2.6.9-67.EL /usr/src/kernels/2.6.9-67.EL-i686
(2)cd /usr/src/kernels/2.6.9-67.EL-i686
(3)make oldconfig
(4)make dep
(5)cd <linux-gpib>
(6)./configure
(7)make
(8)make install
It also says L0 not found, what should I do next?
many thanks in advance
[fel@localhost ~]$ cd EPICS/psm6003/iocBoot/iocPSM6003
[fel@localhost iocPSM6003]$ ../../bin/linux-x86/PSM6003 st.cmd
#!../../bin/linux-x86/PSM6003
## You may have to change PSM6003 to something else
## everywhere it appears in this file
< envPaths
epicsEnvSet(ARCH,"linux-x86")
epicsEnvSet(IOC,"iocPSM6003")
epicsEnvSet(TOP,"/home/fel/EPICS/psm6003")
epicsEnvSet(PSM6003,"/home/fel/EPICS/module/psm6003")
epicsEnvSet(ASYN,"/home/fel/EPICS/4-6")
epicsEnvSet(EPICS_BASE,"/home/fel/EPICS/base")
cd /home/fel/EPICS/psm6003
## Register all support components
dbLoadDatabase("dbd/PSM6003.dbd",0,0)
PSM6003_registerRecordDeviceDriver(pdbbase)
## Load record instances
#dbLoadRecords("db/xxx.db","user=felHost")
dbLoadRecords("db/devPSM6003.db","user=felHost")
GpibBoardDriverConfig("L0",1,0,3,0)
st.cmd -- Line 18 -- Command GpibBoardDriverConfig not found.
iocInit()
Starting iocInit
############################################################################
## EPICS R3.14.9- $R3-14-9-pre1$ $2006/11/20 21:09:36$
## EPICS Base built Dec 30 2007
############################################################################
2008/01/04 11:16:54.163 devSupportGpib:getDeviceInstance link 0 L0 failed asynMa nager:connectDevice port L0 not found
current-in: init_record : no driver for link 0
2008/01/04 11:16:54.163 devSupportGpib:getDeviceInstance link 0 L0 failed asynMa nager:connectDevice port L0 not found
current-out: init_record : no driver for link 0
iocInit: All initialization complete
## Start any sequence programs
#seq sncxxx,"user=felHost"
The CA server's beacon address list was empty after initialization?
epics>
Best wishes
                                                                             deminzhang
 
 
 



网 易 有 道 词 典 -- 全 球 最 强 大 的 免 费 英 汉 互 译 词 典 ( 只 有 2 兆 )
Replies:
Re: problem in running application of PSM6003 Emmanuel Mayssat

Navigate by Date:
Prev: Re: build snl program Emmanuel Mayssat
Next: Re: problem in running application of PSM6003 Emmanuel Mayssat
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  <20082009  2010  2011  2012  2013  2014 
Navigate by Thread:
Prev: Re: build snl program Emmanuel Mayssat
Next: Re: problem in running application of PSM6003 Emmanuel Mayssat
Index: 1994  1995  1996  1997  1998  1999  2000  2001  2002  2003  2004  2005  2006  2007  <20082009  2010  2011  2012  2013  2014 
ANJ, 02 Sep 2010 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICSv4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·