Argonne National Laboratory

Experimental Physics and
Industrial Control System

1994  1995  1996  1997  1998  1999  2000  2001  <20022003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017  Index 1994  1995  1996  1997  1998  1999  2000  2001  <20022003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017 
<== Date ==> <== Thread ==>

Subject: 3.14 vs g++
From: Jim Thomas <thomas@cfht.hawaii.edu>
To: tech-talk@aps.anl.gov
Date: Sat, 6 Jul 2002 15:11:34 -1000 (HST)
Aloha,

What is the "minimum" version of g++ required to build 3.14?  I can't find
any reference in the README's or on tech-talk (possibly because of
malformed search requests, of course).  I'm trying 2.7.2 on
solaris-sparc-gnu and not getting very far.  If I need to get a new version
for epics ....

Somewhat related since I needed to change this (for 2.7.2 ?), is there a
method for adding to CONFIG.gnuCommon:CODE_CXXFLAGS ?  Several os/CONFIG*
files have a "CODE_CXXFLAGS =" or "CODE_CXXFLAGS = <something>", which
unless there is some real magic going on wipes the CONFIG.gnuCommon
definition.  I think I want a os/CONFIG_SITE.<something> line with a
"CODE_CXXFLAGS += -fhandle-exceptions" line to add to the standard ones,
right?

Mahalo,
Jim

Replies:
RE: 3.14 vs g++ Jeff Hill

Navigate by Date:
Prev: Re: waveform calculations Alexei Dmitrovski
Next: RE: 3.14 vs g++ Jeff Hill
Index: 1994  1995  1996  1997  1998  1999  2000  2001  <20022003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017 
Navigate by Thread:
Prev: tnetDrv behavior Peregrine McGehee
Next: RE: 3.14 vs g++ Jeff Hill
Index: 1994  1995  1996  1997  1998  1999  2000  2001  <20022003  2004  2005  2006  2007  2008  2009  2010  2011  2012  2013  2014  2015  2016  2017 
ANJ, 10 Aug 2010 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·