Argonne National Laboratory

Experimental Physics and
Industrial Control System

2012  2013  <20142015  2016  2017  Index 2012  2013  <20142015  2016  2017 
<== Date ==> <== Thread ==>

Subject: Re: epicsqt with Qt5.1.1, Qt-Creator 2.8.1 (also Qt5.2 + QtCreator 3.0)
From: "Alexander S. Aryshev" <alar@post.kek.jp>
To: Andrew Rhyder <Andrew.Rhyder@synchrotron.org.au>
Cc: qti-talk@aps.anl.gov, Anton Maksimenko <antonmx@gmail.com>
Date: Wed, 15 Jan 2014 11:15:57 +0900
Dear Andrew,

Finally I have a good news. I made it work!

The key modification was QEDesignerPlugin.cpp
and QEDesignerPlugin.h files (please find modified versions
in attachment). After that it was successfully compiled and creator
accepted it as a good widget library. I have tested most of it and it
works ok under Qt 5.1 + Creator 2.8. Then I installed Qt 5.2 +
Creator 3.0 and it also works.

Please find complete zip of my epicsqt folder by the following link:
https://www.dropbox.com/s/hq6rn52ghjn9o6j/epicsqt.zip

My future plan is to re-write QEPlot widget to use QCustomPlot
(http://www.qcustomplot.com/) instead of qwt.

Cheers,
Alex

Attachment: QEDesignerPlugin.h
Description: Binary data

Attachment: QEDesignerPlugin.cpp
Description: Binary data


Navigate by Date:
Prev: Happy 2014! Andrew Johnson
Next: new improved version of caQtDM Mezger Anton Christian
Index: 2012  2013  <20142015  2016  2017 
Navigate by Thread:
Prev: Happy 2014! Andrew Johnson
Next: new improved version of caQtDM Mezger Anton Christian
Index: 2012  2013  <20142015  2016  2017 
ANJ, 04 Mar 2014 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·