Argonne National Laboratory

Experimental Physics and
Industrial Control System

2012  <20132014  2015  2016  2017  Index 2012  <20132014  2015  2016  2017 
<== Date ==> <== Thread ==>

Subject: epicsqt with Qt5.1.1, Qt-Creator 2.8.1
From: "Alexander S. Aryshev" <alar@post.kek.jp>
To: qti-talk@aps.anl.gov
Date: Tue, 15 Oct 2013 19:35:16 -0700
Dear QTi-talk,

I am trying to compile epicsqt 2.7.1 with
very standard installation of Qt5.1.1 and install
its plugin into designer under Qt-creator 2.8.1 on
Scientific Linux 6.4 (kernel 2.6.32-358.18.1.el6.i686).

The Creator itself was build from src under the same version of Qt.
The QWT version is 6.1.0. It was also build from src and seems
working ok (all examples are working fine).

EPICS base3.14.12.3 is installed and all env. variables are defined.

After all standard changes http://qt-project.org/wiki/Transition_from_Qt_4.x_to_Qt5
applied to epicsqt 2.7.1 it was built without any errors
(just warnings about QE_ARCHIVE_LIST is not defined).
After that I have defined QT_PLUGIN_PATH pointed to framework folder
where designer folder with libQEPlugin.so was.

Unfortunately this library always return
"Plugin verification data mismatch" on loading.

Does anyone had a similar problem and know how to solve it?

Below is a list of my environment.

With the best regards,
Alex


Qt 5.1.1 (Qt-5.1.1)
ABI: x86-linux-generic-elf-32bit
Source: /usr/local/Qt-5.1.1
mkspec: linux-g++
qmake:  /usr/local/Qt-5.1.1/bin/qmake
Version: 5.1.1
QMAKE_SPEC linux-g++
QMAKE_VERSION 3.0
QMAKE_XSPEC linux-g++
QT_HOST_BINS /usr/local/Qt-5.1.1/bin
QT_HOST_DATA /usr/local/Qt-5.1.1
QT_HOST_LIBS /usr/local/Qt-5.1.1/lib
QT_HOST_PREFIX /usr/local/Qt-5.1.1
QT_INSTALL_ARCHDATA /usr/local/Qt-5.1.1
QT_INSTALL_BINS /usr/local/Qt-5.1.1/bin
QT_INSTALL_CONFIGURATION /usr/local/Qt-5.1.1/etc/xdg
QT_INSTALL_DATA /usr/local/Qt-5.1.1
QT_INSTALL_DEMOS /usr/local/Qt-5.1.1/examples
QT_INSTALL_DOCS /usr/local/Qt-5.1.1/doc
QT_INSTALL_EXAMPLES /usr/local/Qt-5.1.1/examples
QT_INSTALL_HEADERS /usr/local/Qt-5.1.1/include
QT_INSTALL_IMPORTS /usr/local/Qt-5.1.1/imports
QT_INSTALL_LIBEXECS /usr/local/Qt-5.1.1/libexec
QT_INSTALL_LIBS /usr/local/Qt-5.1.1/lib
QT_INSTALL_PLUGINS /usr/local/Qt-5.1.1/plugins
QT_INSTALL_PREFIX /usr/local/Qt-5.1.1
QT_INSTALL_QML /usr/local/Qt-5.1.1/qml
QT_INSTALL_TESTS /usr/local/Qt-5.1.1/tests
QT_INSTALL_TRANSLATIONS /usr/local/Qt-5.1.1/translations
QT_SYSROOT
QT_VERSION 5.1.1

gcc -v
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/local/libexec/gcc/i686-pc-linux-gnu/4.8.1/lto-wrapper
Target: i686-pc-linux-gnu
Configured with: ./configure
Thread model: posix
gcc version 4.8.1 (GCC) 


Replies:
RE: epicsqt with Qt5.1.1, Qt-Creator 2.8.1 Emmanuel Mayssat

Navigate by Date:
Prev: Free 1-day training on Qt Emmanuel Mayssat
Next: RE: epicsqt with Qt5.1.1, Qt-Creator 2.8.1 Emmanuel Mayssat
Index: 2012  <20132014  2015  2016  2017 
Navigate by Thread:
Prev: Free 1-day training on Qt Emmanuel Mayssat
Next: RE: epicsqt with Qt5.1.1, Qt-Creator 2.8.1 Emmanuel Mayssat
Index: 2012  <20132014  2015  2016  2017 
ANJ, 16 Oct 2013 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·