EPICS Collaboration Meeting – Fall 2011 – LabVIEW and EPICS
Exercise 1: Verifying and configuring setup

Goal: In this exercise, you will adjust the configuration of the project so that it works with your physical setup. 
1. Open EPICS.lvproj in the EPICS Training\Exercises directory. The project should look like the Project Explorer view shown in Figure 1. [image: ]
Figure 1. Project Explorer view of EPICS.lvproj

2. Right-click on the cRIO-9014 EPICS controller and select Properties. Under the General category, set the IP Address to the IP Address of the system you are targeting.
3. Expand the chassis item labeled Chassis and verify that the modules and slots match the modules and slots of your setup
4. Label the channel of your setup measuring temperature Temp. For example if the temperature is being measured on AI1. Expand the module item labeled Mod1 and rename AI1 to Temp. 
5. Similarly modify the names under Mod2 match your setup. Heat is on DO0 and Cool is on DO1. 

 
6. Expand the VIs folder and open Test.vi. Look at the block diagram and verify that the variables are linked and relink as necessary. Save the VI if you made changes. 
7. Run the VI and verify that you can measure temperature, turn on and off the light (heater), and turn on and off the fan (cooler). 
8. Stop, close, and save the VI. 
9. From the menu bar of the Project Explorer window select File » Save All (this Project). Leave the project window open for later. 

End of Exercise 1




Exercise 2: Setup a simple temperature control VI

Goal: In this exercise, you will setup a simple temperature controller to be used in later exercises. 
1. Open EPICS.lvproj in the EPICS Training\Exercises directory if not already open. 
Note that Exercise 1 must be completed before doing this exercise. 
2. Under cRIO-9014-EPICS, right-click on the VIs folder and select Add » File. Locate the EPICS Training\Exercises\VIs directory and select Control.vi and click Add File. The front panel of the VI is shown in Figure 2. [image: ]
Figure 2. Front Panel of Control.vi

To automate the temperature control we will create a simple control algorithm to turn on the light if the temperature is below a setpoint and to turn on the fan if the temperature is above the setpoint. We will also have a hysteresis or “dead band” so that the light or fan doesn’t turn on if the temperature is “close to” the setpoint.  
3. Update the block diagram so that is looks like Figure 3. Remember that you can drag and drop the I/O Nodes like Temp directly from the Project Explorer window to the block diagram. To change the direction of a Shared Variable, right-click on the variable and select Access Mode » Read or Write. [image: ]
Figure 3. Block diagram of Control.vi

4. Run the VI and verify that the temperature moves, if slowly, toward the setpoint. Once near the setpoint, it is normal for the fan or light to turn on and off to keep the value near the setpoint. 
5. Stop, close, and save the VI. 
6. From the menu bar of the Project Explorer window select File » Save All (this Project). Leave the project window open for later. 

Challenge Exercises
· Add indicators for when Heat and Cool are on. 
· Add cursers to the graph to show the location of the setpoint. 
· Add a light to indicate when the temperature is within the hysteresis of the setpoint. 
End of Exercise 2


Exercise 3: Use the simple temperature control VI to create an EPICS CA Server

Goal: In this exercise, you will create an EPICS CA Server out of the Control.vi.
Create Shared Variables
1. Open EPICS.lvproj in the EPICS Training\Exercises directory if not already open. 
Note that Exercise 2 must be completed before doing this exercise. 
2. To create a virtual folder, right-click on the cRIO-9014-EPICS controller and select New » Virtual Folder and name the folder Libraries. 
3. To create shared variables, right-click on the Libraries folder and select New » Variable. Name the variable Temperature and click OK. Notice that a library was automatically created and Temperature was placed under it as shown in Figure 4. [image: ]
Figure 4. Project Explorer after just creating the Temperature variable. 

4. Save the automatically created library by right-clicking on the library and selecting Save » Save As. Save the library in the EPICS Training\Exercises\Libraries directory as Variables. 
Note that you will have to create the Libraries directory. 
Note that.lvlib is automatically added to the library name when saving. 
5. Create a second variable by right-clicking on Variables.lvlib and selecting New » Variable. Name the variable SetPoint. 
Create EPICS Server I/O Server and connect to shared variables
6. Now create an EPICS Server I/O Server by right-clicking on the Libraries folder and selecting New » I/O Server. Select EPICS Server and click Continue. 
7. In the Configure EPICS Server I/O Server dialog shown in Figure 5, Click on Add/Remove Variables. [image: ]
Figure 5. Configure EPICS Server I/O Server dialog

8. In the Add Remove Variables dialog shown in Figure 6, locate the two variables just created in the tree control on the left and add them one at a time by clicking Add. [image: ]
Figure 6. Add/Remove Variables dialog

9. Click OK to close the dialog. The Configure EPICS Server I/O Server dialog reappears showing the two variables listed with their new PV names. 
10. Because we are going to type these names later, rename the PVs to setp and temp respectively by clicking twice on the PV names. 
Note that clicking twice is not a double-click. A double-click doesn’t allow you to change the name. You must single-click twice. 
11. Once the PVs have been renamed, click OK. Notice that another library has been created with an EPICS Server under it. 
12. Save the library by right-clicking on the library and selecting Save » Save As. Save the library in the EPICS Training\Exercises\Libraries directory as Server. 
Note that .lvlib is automatically added to the library name when saving. 



Edit Control.vi to use the variables

13. Modify Control.vi block diagram to look like Figure 7. Notice that the Temperature and SetPoint variables have been added from the project and that the SetPoint Control was changed to an indicator. [image: ]
Figure 7. Block diagram of modified Control.vi

14. Right-click on the Server library and select Deploy. 
15. Save and run Control.vi.

Use EPICS Windows Tools to verify EPICS Server

16. If not already installed, follow the instruction at the following location to install the EPICS Windows Tools: 
“How Can I Troubleshoot EPICS Network Connectivity” http://digital.ni.com/public.nsf/allkb/0DC1D4FC7164D1BF8625760500795082 
(This can also be found on ni.com by searching for “Troubleshoot EPICS”)
17. Once installed or to verify installation open the command prompt by typing “cmd” (without the quotes) in the Start Menu.
18. Type the following (if the directory exists and “caget” is found, then it is installed):
cd “c:\Program Files\EPICS Windows Tools” (to change directory)
caget temp (to get the value of temp from EPICS channel access network, timeout on first try)
caget temp (to get the value of temp)
Note that the first read times out because the server is establishing a connection. After the first read then the value is returned within the timeout period without producing the timeout warning. 
The command window should look like Figure 8. [image: ]
		Figure 8. Command window showing output of suggested commands

19. In the command window type “caput setp 29” (without the quotes) and notice how the SetPoint indicator on the Front Panel of Control.vi changes (you may have to do it twice because it fails the first time). 
20. Type “camonitor temp” (without the quotes) and notice the output on the command prompt window shows a new value for temp every time the Temperature shared variable is written to. 
21. Hit Ctrl-C to stop the monitor. 
22. Stop, close, and save the VI. 
23. From the menu bar of the Project Explorer window select File » Save All (this Project). Leave the project window open for later. 

Challenge Exercises
· Allow manual update of setpoint on the server
· Publish over EPICS the status of whether the system is cooling, heating, or idle (Either as multiple Booleans or as a single status). 
· Make up a safe range for the temperature and publish a status to warn over EPICS when the temperature is outside the safe range. 
End of Exercise 3


Exercise 4: Create an EPICS CA Client

Goal: In this exercise, you will create an EPICS CA Client to monitor the EPICS CA Server. 
Create EPICS Client I/O Server on Host Computer
1. Open EPICS.lvproj in the EPICS Training\Exercises directory if not already open. 
Note that Exercise 3 must be completed before doing this exercise.
2. In Project Explorer, right-click on My Computer and select New » Virtual Folder. Name the folder Libraries. 
3. Right-click on the Libraries folder and select New » I/O Server. Then select EPICS Client and select Continue. You will then see the Configure EPICS Client I/O Server dialog as shown in Figure 9.
[image: ]
		Figure 9. Configure EPICS Client I/O Server dialog

4. Click Add Record, then under the Attributes section in the Name field type the name temp.
5. Add another record and this time name the record setp. Click OK. Notice that a new Library was created. 
6. Right-click on the new library and select Save » Save As. Save the VI in the EPICS Training\Exercises\Libraries directory as Client. 
Note that .lvlib is automatically added to the library name when saving.
Create Shared Variables
7. Right-click on EPICS Client1 and select Create Bound Variables. You will then see the Create Bound Variables dialog similar to Figure 10. [image: ]
Figure 10. Create Bound Variables dialog

8. As shown in Figure 10, locate and select the VAL field of setp. Click on the checkbox next to Custom-base name and type in the name CSetPoint as the name of the new shared variable.
9. Do the same for VAL field of temp and name its shared variable CTemp. 
10. Click OK. The dialog will close and the Multiple Variable Editor will open. Uncheck Network-Published: Buffering for both variables. 
11. Click Done on the Multiple Variable Editor. The variables will be created under the Client.lvlib library. 
Create Client VI
12. In the Project Explorer, right-click on My Computer and select New » Virtual Folder. Name the folder VIs. 
13. Right-click on the VIs folder and select Add » File. Locate the EPICS Training\Exercises\VIs directory and select Client.vi and click Add File. The front panel of the VI looks similar to Control.vi and is shown in Figure 11. [image: ]
Figure 11. Front Panel of Client.vi

14. Modify the block diagram to look like Figure 12. [image: ]
Figure 12. Client.vi Block Diagram

15. Save Client.vi. 
16. Run Control.vi and Client.vi. Try changing values in Client.vi and see the affects. Notice that Client.vi will get an error on the first call. 
17. Stop, close, and save the VIs. 
18. From the menu bar of the Project Explorer window select File » Save All (this Project). Leave the project window open for later. 

Challenge Exercises

· Look at Distributed System Manager and find the value of the PVs on both the Server and the Client. 
· Program the Client to only send SetPoint values on data change. 
· Program the SetPoint on the Client to show the value if another client changes it. 
· Modify the Client VI so that it does not error when first run.

End of Exercise 4


Exercise 5: Use the EPICS CA Server Programmatic API

Goal: In this exercise, you will use the CA Server Programmatic API to programmatically create Process Variables (PVs)
1. Open EPICS.lvproj in the EPICS Training\Exercises directory if not already open. 
Note that Exercise 4 must be completed before doing this exercise.
2. Start by deleting Server.lvlib under cRIO-9014-EPICS » Libraries folder by selecting the library and hitting the Delete key. 
3. Right-click on cRIO-9014-EPICS and select New » Virtual Folder. Name the virtual folder RenameVIs. 
4. Right-click on the RenameVIs folder and select  Add » File. Use shift-click to add all files under the EPICS Training\Exercises\RenameVIs directory. 
5. Use RenameWithPrefix.vi in the RenameVIs virtual folder to modify Control.vi to look like Figure 13. 
Note that this code could be added to any VI using shared variables to automatically create an EPICS Server and use a file to add a prefix and rename the PVs. The code parses the names in the INI file, matches the names of the shared variables, and creates PVs using the prefix in the INI file and the substitute names specified in the INI file. 
[bookmark: _GoBack][image: ][image: ]
Figure 13. Block Diagram of Control.vi

6. Save Control.vi. 


7. Create a text file and save it in the EPICS Training\Exercises\RenameVIs directory as PVnames.ini. Type in the text to make the file look similar to Figure 14. 
Note that the prefix will be “NI” and each variable has a substitute name of “sp” and “tp” respectively. 
[image: ]
		Figure 14. PVnames.ini open in Notepad

8. Open Measurement and Automation Explorer (MAX) and right-click on the controller under Remote Systems and select File Transfer. 
9. Click OK to log in with a blank user name and password. 
10. Copy PVname.ini from the EPICS Training\Exercises\RenameVIs directory to the root directory of the controller. 
11. After successfully copying the file, click Close to close the File Transfer dialog. 
12. Run Control.vi.
13. Open the command prompt by typing “cmd” (without the quotes) in the Start Menu. 
14. Type the following:
cd “c:\Program Files\EPICS Windows Tools” (to change directory)
caput NI:sp 29 
Notice that the SetPoint value on Control.vi changed to the value of 29. 
Type camonitor NI:tp to monitor the temperature. 
15. Hit Ctrl-C to stop the monitor. 
16. Close the command window and stop and close Control.vi. 
17. From the menu bar of the Project Explorer window select File » Save All (this Project). Close the project window. 


Challenge Exercises
· Publish over EPICS the status of whether the system is cooling, heating, or idle (Either as multiple Booleans or as a single status).  Add this value to the text file. 
· Make up a safe range for the temperature and publish a status to warn over EPICS when the temperature is outside the safe range. Add this value to the text file. 
· How would you change the code to use it on multiple systems? 
End of Exercise 5
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