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EPICS

Introduction !EI

¢ What is Capfast and why?
¢ How does it map to the EPICS database?
¢ Capfast tutorial
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EPICS

What is Capfast and why?
o

& Schematic capture tool typically used for circuit design.

+ Not the leading schematic capture tool today

+ | think it was stronger in the early days.
¢ Started as a UNIX tool and other Windows tools passed it by

& ... however it is very easily configurable
+ All schematics, symbols and configurations & menus are text files
¢ Outputs a standard net-list format.

+ ... and has some powerful features:

& Provides hierarchical drawings to structure a database
¢ Provides bus-mechanisms for bundling links
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EPICS

How does Capfast map to a0
EPICS?

Electronic parts EPICS Records
Part type (e.g. Resistor) Record Type (e.g. Analog in)

Property (e.g. Resistancekield value (e.g PREC=3)
Pins Links or Field inputs
Connections Link connections
Fabrication make
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EPICS

Differences !EI

¢ EPICS records typically have more fields than electronics
parts have configurable properties, so this is area is
handled poorly.

¢ EPICS data links push or pull data from fields (which are
passive), so connection diagrams are a bit confusing at
first:

+ Fundamentally, there can only be one field in a single, multiply
connected, wire.

+ Any output link will push into this field.
+ Any input link will pull data from this field.

+ Links also imply processing depending on the properties of the
link.

april 2091: BYO@Ssifgdinks pass no data and can only be connected to 5
ST.NK



EPICS

Capfast tutorial
o

¢ Capfast has two editors:

¢ xschedit for schematics
¢ xsymed for symbols.

¢ You create new symbols to encapsulate other drawings
and build a drawing hierarchy.
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EPICS

The basics
o

¢ <Esc> key aborts current operation.

¢ Mouse buttons are context sensitive and their meanings
are given at the top of the screen.

¢ Menu shortcuts available by using the underlined letter
(no <A1t> required on Unix).

+ Number keys or arrow keys can be used for scrolling (5
centers the schematic on the screen).

¢ V R shortcut (View Redraw) will force a redraw.
¢ Menu’s are PC or Motif like.

¢ Clicking in the drawing area sets up markers for the next
command (e.g. define a wire route).
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EPICS

Schedit screen

B schedit i =10x]
File Edit Part Text MWire Properties Hierarchy Select Wiew Configure Options  Help
(1104 1744) PFOINT | EEPEAT | UNEOINT (228 Z2328)

Cstt Schedi; 3.02 Eiting:l{Unitedj . lign:lfi Ad:NNE .
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EPICS

Getting a border

B schedit =10 x|
File Edit | part Text MWire Properties Hierarchy Select Wiew Configure Options Help
{1104 izet By Name - | - | - (181 Z38/Z2)

Schematic Conneckars  k . . . .
Borders Complete border {with title + rev. bl
Border only

Revision block only

Title block anly

Epics library

Cstt Schedi; 3.02 Eiting:l{Unitedj . lign:lfi Ad:NNE .
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Got a border, now add a record

File Edit | part Text MWire Properties Hierarchy Select Wiew Configure Options Help

=10l x|

ek By Mame —-——— | ===

Schematic Conneckars  k

----- Borders *

Epics library analog in {large)

event (small)
......... analog in {small) fFanout (large)

permissive [large)
permissive [small)

(534 6204)

stringouk (s
subroukineg 1

e analog in {sirn) Faraut {small) pid {large) subroutine |
----------------- analog ouk [large) histogram (large) pid (smally timer {large
e analog ouk (smally histagrar (small) pulsetrain (large) kirner (srnall
----------------- analog ouk {sim) longin {large) pulsetrain {smally waveform {
R binary in {large) longin {smally select (large) waveform {
""""""""" binary in {small} longout {large) select (small) waveout (|
U binary ouk (large) [ongout {small) sequence (large] wavenuk (s
""""""""" binary ouk (smally multibit Binary in (L) sequence (small) hardware ir
I calculation (large) multibit binary in (53 stake (large) hardware o
I R calcout (smally multibit binaty ouk (L) skake (small) ramp [large
----------------- calcout (large) multibit binary ok (53 steppermotar (large) ramp (small
[ calculakion Csrmall) pulsecounter (large) stepperrnator (small) data Famaut
----------------- compression {large) pulsecounterismall) skringin (large) data Fanout
[ I compression {small) pulsedelay {large) stringin {srall)

----------------- envent ¢large)

Ad]:NONE

CapFast Schedit, 3.02 Editing: (Untitled)

pulsedelay {small)

skringout {large)

Align: 1a

April 2001: JAC EPICS Course
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EPICS

Place it and give it a name

File Edit Part Text Wire Properties Hierarchy Select Wiew Configure Options  Help
(11ed 5472) PFOINT | EEPEAT | UNEOINT (1175 B487)

=10l x|

CapFast Schedit, 3.02 Editing: (Untitled) Align: 1a Ad]:NONE
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Get a calculation record EPICS

i ' =100 x|
File Edit | part Text MWire Properties Hierarchy Select Wiew Configure Options Help
izet By Name - | - | - (1029 5071

Schematic Conneckars  k

----- Borders *

""" Epics library analog in {large) event (small) permissive [large) stringouk (s

----------------- analog in {small) fFanout (large) permissive [small) subroukineg 1
e analog in {sirn) Faraut {small) pid {large) subroutine |
----------------- analog ouk [large) histogram (large) pid (smally timer {large
e analog ouk (smally histagrar (small) pulsetrain (large) kirner (srnall
----------------- analog ouk {sim) longin {large) pulsetrain {smally waveform {
[ I binary in {large) longin {smally select (large) waveform {
"""""""" binary in {small} longout {large) select (small) waveout (|
A binary ouk (large) [ongout {small) sequence (large] wavenuk (s
"""""""" binary ouk (smally multibit Binary in (L) sequence (small) hardware ir
A calculation (large) multibit binary in (53 stake (large) hardware o
""""""""" calcout (smally multibit binaty ouk (L) skake (small) ramp [large

----------------- calcout (large) multibit binary ok (53 steppermotar (large) ramp (small
S calculation (smally pulsecounter (large) steppermatar (small) data Fanout
----------------- compression {large) pulsecounterismall) skringin (large) data Fanout
[ I compression {small) pulsedelay {large) stringin {srall)

----------------- envent ¢large) pulsedelay {small) skringout {large)

CapFast Schedit, 3.02 Editing: (Untitled) Align: 1a Ad]:NONE
E i file.....¢
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EPICS

Place it and give it a name

File Edit Part Text Wire Properties Hierarchy Select Wiew Configure Options  Help
(1154 E5278) PFOINT | EEPEAT | UNEOINT (959 5378)

=10l x|

CapFast Schedit, 3.02 Editing: (Untitled) Align: 1a Ad]:NONE
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EPICS

Add an output record

B schedit =10 x|
File Edit Part Text Wire Properties Hierarchy Select Wiew Configure Options  Help
(1a00 54838) PFOINT | EEPEAT | UNEOINT (773 /097

tiUntitled) Align: 1a Ad]:NONE
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Click twice and connect them up E7°°

B schedit =10 x|
File Edit Part Text | \Wire Properties Hierarchy Select Wiew Configure Options Help
(1152 E5EA9A) Drraiy Wilire | - | -
Extend ‘Wire

........... Draw Bus

Extend Bus

......... . Re-Route

B e Svmbol e
..... Bustap Symbal

CapFast Schedit, 3.02 Editing: (Untitled) Align: 1a Ad]:NONE
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EPICS

Wired up...

B schedit =10 x|
File Edit Part Text Wire Properties Hierarchy Select Wiew Configure Options  Help
(1024 E5EA9A) PFOINT | EEPEAT | UNEOINT (1387 5199)

CapFast Schedit, 3.02 Editing: (Untitled) Align: 1a Ad]:NONE
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Next wire EPICS

B schedit =10 x|
File Edit Part Text MWire Properties Hierarchy Select Wiew Configure Options  Help
(944 /224) PFOINT | EEPEAT | UNEOINT (1017 /l132)

CapFast Schedit, 3.02 Editing: (Untitled) Align: 1a Ad]:NONE
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EPICS

Add hardware inputs and

i ' =10l x|

File Edit | part Text MWire Properties Hierarchy Select Wiew Configure Options Help

Get By Mame

Schematic Conneckars  k

----- Borders *

""" Epics library analog in {large) event (small) permissive [large) stringouk (s

----------------- analog in {small) fFanout (large) permissive [small) subroukineg |
e analog in (i) Fanout {small) pid (large) subroutine |
----------------- analog ouk [large) histogram (large) pid (smally timer {large
[ I analag aut {srmall) histagrar (small) pulsetrain (large) kirner (small
------------ analog ouk {sim) longin {large) pulsetrain {smally waveform {
N binary in {large) longin {smally select (large) waveform {
"""""""" 4 binary in {small} longout {large) select (small) waveout (|
I A binary ouk (large) [ongout {small) sequence (large] wavenuk (s
"""""""" binary out (srmall} rulkibit binary in (L) seguence (small) hardware i

....... A calculation (large) multibit binary in (53 stake (large) hardware o
[ R calcout (smally multibit binaty ouk (L) skake (small) ramp [large
----------------- calcout (large) multibit binary ok (53 steppermotar (large) ramp (small
[ I calculation (smally pulsecounter (large) steppermatar (small) data Fanout
----------------- compression {large) pulsecounterismall) skringin (large) data Fanout
I compression {small) pulsedelay (large) stringin (small)

----------------- envent ¢large) pulsedelay {small) skringout {large)

CapFast Schedit, 3.02 Editing: (Untitled) Align: 1a Ad]:NONE
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EPICS

Done

B schedit =10 x|
File Edit Part Text Wire Properties Hierarchy Select Wiew Configure Options  Help
(B5E 57440 PFOINT | EEPEAT | UNEOINT (1laa? BARO4)

CapFast Schedit, 3.02 Editing: (Untitled) Align: 1a Ad]:NONE
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Hardware inputs and outputs o>

%

¢ These are a method of putting constant values into link
fields.

¢ The val(outp) and vap(in) properties contain the string value that
the link field will be set to.

+ Normally used for hardware, but also can be used to link to a

record of a know name, which doesn’t appear in the current
drawing hierarchy.

April 2001: JAC EPICS Course 20



EPICS

Edit these properties

B schedit 10l x|

File Edit Part Text MWire | Properties Hierarchy Select Wiew Configure Options Help
(816 A0D96) | - | - (BEE AL37)

Schedit, 3.02 Editing: (Untitled) Align: 1a Ad]:NONE

» 1n progress
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Z& & & &6 o o

EPICS

Property (field) editing a0

Hame: |val[uutp]

Value: [#CO 50 @

primitive: hwout
typloutp]:val
val[outp]: #CO 50 (@&

Click on the property line and edit in the Value box.
Add/Modify saves the change.
Display... allows you to set the display attributes.
Delete deletes the field - or returns it to the default value.
Move moves the highlighted properties (fields).

. Gopy. allows you to copy properties to other records.

S Course 22



A more
typical
record
(UNIX)

April 2001: JAC EPICS C«

nTYP
Tvecom ¥YSER

ADEL:O.0O0000000000000e+00
SOFF0.0000000e+00
SSLOT1.0000000e+00
DESC:analog input record
DISS:ND_.ﬂ.L.ﬁ.RM

EGLL uolts
EGQUF:0.0000000e+00)
EQUL:0.0000000e+00)
EWVMT:O

HHSWVNO _&LARM
HIGH:D.0000000a+00
HIHED.0Q00000a+00
HOPR:O,0000000e+00
HSWVNO_aLARM _
HYST:0.000000000000000e+00
LINR:LINE&R
LLSW:NO_ALARM
LOLGC:O.0000000e+00
LOFPR:0.0000000a+00
LOWw,0.0000000e+00
LavViNO_aLARM

PMOEL:D, DOOOOOOODDDOODDE+DG
FHAS:O

FINEMNO

FREC:O

FRIC:LOW

SCaM:Passive

SIML:0.000000000000000e+00

SIMS MO _ALARM
SIOL0.000000000000000e+00
SMOO:0.0000000e+00

Type:ai

def{FLM KO0 ODDDDDDDDDODDDDE+DD
def{Il N PR0.000000000000000e+00

EPICS
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Edit more properties etc... ERes

B2 schedit . =10 x|
File Edit Part Text ‘Wire Properties Hierarchy Select Wiew Configure  Options Help
(a0 POIMNT | EEPEAT | UNEBOINT (2042 /0O85)

CapFast Schedit, 3.02 Align:1é Ad]:NONE

rarn (g

Command aborted

April 2001: JAC EPICS Course 24
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EPICS

Commonly used items
o

File->Hierarchy->Descend (or Ascend)
File->Hierarchy->Create Symbol from Schematic
Edit-> anything!

View->Redraw

View->Zoom Area

Part->Schematic Connectors->Hierarchical Input
Part->Borders

Part->Epics Library->

Text-> anything!

Wire->Draw Wire

Wire->Reroute
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EPICS

Commonly used items (ctd) a0

Properties->Edit
Select->ltems
Select->More Items
Select->Area
Select->Symbol to Replace
Select->Clear

® & 6 6 o o
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Different Symbol Styles

File Edit Part Text Wire Properties Hierarchy Select  View Configure  ©pkions

=1

" Soft Chanmel

- DESCianaleg tnput -record -

SCAM:Passtwe © ° HIHI:Q, GHREEEE.+EE
PHAS:@ ~ ~ ~  LOL0:6. 503006-+30
EWNT:8 ~ 7 7 HIEH:d. CHREEEE.+8IE
PINI:NOD ~ ~ ~  LOW:9.pE00606.+00
LIMR:LIMEAR ~ ° HHSW:HO_ALARM
PREC:& ~ °~ ° ° HSV:NO_ALARH
EGUF: &, GREEE0H:+EE LSY: NO_ALARH
EGUL: 8. GRBEAER.+BE LLSY : HO_ALARM
EGU:wolts © 7 DISS:HO_ALARM
HOPR: &, BREEEEE:+EE PRIO:LOL
LOPR: @, BEAAAEA=+AA AOFF: 0. GEAAAEE.+30
RSLO: 1 GREEEEE.+EE SMO0:Q , GHREREEE.-+3IE
ey
HYST: &, BREHEEEREREEEAEE+E0

ADEL : @, BRAEAEGARREERAG+0A

MOEL : & HREHEEHREREEEHEE+E0

SI0L: Q. BEAEREGARREERRG-+0A

SIML: 8. HREHEnEREREEEaEE+E0

SIMS: HO_ALARM C

Editing: (Untitled) Align: 1é Ad]j:NONE rid: 32

Pleaze pozition
Instance name? small




EPICS

User defined ports
o

+ Note that the larger symbols have ports with names like
FLDO, FLD1 etc.

¢ These are ports with user defined names.

+ Names are defined by editing a property called username (u0)
(or ul, u2 etc).

¢ Replace the default value of that property (FLDO0) with the name
of the field you want the connecting link to refer to (e.g. SCAN).
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EPICS

%

Hierarchical Schematics

¢ Use xschedit to design the lower levels of the
hierarchy.

& Use hierarchical connectors for off page connections.

¢ Use xsymed to create a symbol of the same name which
encapsulates the lower level schematic,

¢ The pin-out should have pins with the same name as the
hierarchical connectors.

& This can be simplified slightly using:
File->Hierarchy->Create Symbol from Schematic
¢ EPICS symboils typically have flying leads that are two grid boxes
long, with the field name written above the flying lead.
¢ Use xschedit to create another schematic which
Al ipediporatescthe new symbol. 2



Hierarchies (ctd)

EPICS

%

& Parameters can be passed into a hierarchical symbol by:

¢ Using the form $ (parameter) where ever the parameter is used
In the included schematics.

+ Defining a property of the symbol (in xsymed) with a name
beginning with ‘set’ and a value of the parameter name, space
and then the value.

¢ Example: the parameter test will be set to the value:

‘A parameter va

The last character of the
set name is

unimportant. It just
makes the property
name unique.

April 2001: JAC EPICS Course

Properties

Hame: |set1 | [" Bead Only

setl-test A parameter value for the parameter test
setZ2-pazsed A parameter value for the parameter passed

Value: (test A parameter value for the parameter test

[~

o

Dizplay. ..

Delete

_ Dokte |
_ Move |

Move

30




Hierarchical record names !E"El'cs

¢ By default, record names have the form:
¢ <schematic name>:<symbol name>
¢ Symbols in hierachically included diagrams have the
form:
¢ <schematic name>:<symbol name level 1>:.:<symbol name>
¢ There is a maximum length to record names of 28
characters - so if the hierarchy is deep, keep names
short.

¢ PV and name properties can over-ride the default naming
conventions, but | have never had to use them.
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Printing !E"El'cs

¢ Aliases schprint and symprint to print a schematic as
on letter sized paper on the default printer.
¢ Look at their definition for more details.
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EPICS

Starting up mo_

¢ xschedit and xsymed take three command line
options:
& -k : specifies or adds to the menu search path
¢ -p : specifies or adds to the symbol search path
¢ —w . specifies the number of lines in the text region.

¢ Example:

xschedit -p+S{EPICS BASE}/templates/capfast/sym \
-kS{EPICS BASE}/templates/capfast+

¢ The + Is significant since is says whether to pre-pend or
append to the path.

¢ The file cad. rc contains the default options

& Searched for first in your local directory, then in your home
April 2001 AitefRtoTydPfd finally in the the capfast directories. 33



& Startup commands can be put into schedit.rc or
symed. rc In your home directory.

¢ You can copy schedit.rc from ~npr:

:constralnprops epics.rules
:set libchoice epics

Starting up (ctd)

:mload schedit?

:set
:set
:set
:set
:set
:set

asksnames YES
askwnames NO
askpnames YES
cellnames YES
wlirenames NO
cpylnst YES

April 2001: JAC EPICS Course

EPICS

%

=>Constrains property values
=>Selects epics parts library
=>Reloads the menus

34



EPICS

Turning Schematics into a0
Databases

¢ Done using make

¢ Specify the database name (extension of . db) using the
DATA make variable in Makefile.Host.

¢ The must be a schematic of the same name, but with
extension . sch.

¢ Dependencies are currently broken, so hierarchies are
not handled well - you have to touch the top schematic.
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EPICS

Exercise
o

¢ Create an example application with a capfast, d1 and
startup directories using applSetup.pl

¢ Create a schematic similar to the one shown In this talk.
However, use your imagination if you like!
+ Use the simulation fields and add some simulated plant feedback.

+ Edit the example startup.vws to include your database.
¢ Load onto the VME crate.

¢ Create a display to change the set-point, and graph the
results.
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