g+
g+ Communities
Argonne National Laboratory

Experimental Physics and
Industrial Control System

2002  2003  2004  2005  <20062007  2008  2009  2010  2011  2012  2013  2014  Index 2002  2003  2004  2005  <20062007  2008  2009  2010  2011  2012  2013  2014 
<== Date ==> <== Thread ==>

Subject: 3.14.8 / cygwin dependency
From: Ralph Lange <Ralph.Lange@bessy.de>
To: EPICS Core Talk <core-talk@aps.anl.gov>
Date: Fri, 20 Jan 2006 17:55:25 +0100
Hi -

I just realized that 3.14.8 on Win32 needs cygwin to be compiled. (I.e. the make run breaks without it.)

Up to and including 3.14.7 the Windows builds were working perfectly using the native Windows Commandline Shell. I never used cygwin, I never installed cygwin, and I was actually quite happy without it. (Among other things it allowed me to simply reject all cygwin-related questions that local people were asking me. And there were a lot of those.)

So: Is this intentional?
If yes: What change between 3.14.7. and 3.14.8 was important enough to justify adding an additional package to the prerequisites list for Windows? Shouldn't there be a word in the release notes about that?

Hmmm ..... I still don't see why we have to depend on cygwin - can anyone explain?

Cheers,
Ralph


Navigate by Date:
Prev: Re: Revision numbers Ralph Lange
Next: Re: Revision numbers Andrew Johnson
Index: 2002  2003  2004  2005  <20062007  2008  2009  2010  2011  2012  2013  2014 
Navigate by Thread:
Prev: Re: Revision numbers Andrew Johnson
Next: Re: 3.14.8 / cygwin dependency Ralph Lange
Index: 2002  2003  2004  2005  <20062007  2008  2009  2010  2011  2012  2013  2014 
ANJ, 02 Feb 2012 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICSv4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·