Argonne National Laboratory

Experimental Physics and
Industrial Control System

Base 3.14 Release Series

This is the "Maintenance" release series.

Continuous Integration

The latest code from the 3.14 branch gets built and tested on a linux-x86_64 system whenever changes are committed to the Git repository at https://git.launchpad.net/epics-base. The build status for 64-bit Linux builds can be found here.

Point Releases

There have been many releases of the 3.14 version of Base. Each has its own page containing links to documentation and the relevent files in the software download area. Released versions may have subsequent patch releases, which are documented under the parent version number (e.g. R3.14.12.3)

Platforms Supported

The following host platforms are supported in the latest release above:

  • Solaris on sparc or x86, using Sun's compiler or GCC
  • MS Windows on x86 or x64 using MS Visual Studio, Cygwin, or MinGW
  • GNU/Linux on x86, x86_64, PowerPC, ARM or Cris
  • MacOS X (Darwin) on x86 or PowerPC

These IOC target platforms are currently supported:

  • vxWorks 5.4.x or 5.5.x (Tornado 2.x) on any CPU previously supported.
  • vxWorks 6.x on powerPC CPUs.
  • RTEMS releases up to 4.10.x on any previously supported CPU.
  • GNU/Linux on x86 or x86_64
  • MacOS X (Darwin) on PowerPC or x86
  • WIN32 on x86
  • Solaris on sparc or x86

Software Download

Tarfiles of released versions of Base can be retrieved from the Base Download area.

The source code for all release branches of Base can be obtained using git by cloning the URL https://git.launchpad.net/epics-base — to check out just the 3.14 branch use this command:

git clone -b 3.14 https://git.launchpad.net/epics-base

Related Software

All hardware support, the sequencer, gpib support, and some other products have been unbundled from base. Versions of the sequencer and gpib that have been converted to R3.14 are available from the links below. Other hardware and software support modules may be found via the hardware support database, but might not have a R3.14 version available.


ANJ, 09 May 2017 Valid HTML 4.01! · Home · News · About · Base · Modules · Extensions · Distributions · Download ·
· EPICS V4 · IRMIS · Talk · Bugs · Documents · Links · Licensing ·