
 Fast CCD Detector – User Guide 

 
 
 
 
 
 

Fast CCD Detector 
Quick Start Guide 

 
Revision 6-21-2010 
By: John Weizeorick 

 
Argonne National Laboratory 

Advanced Photon Source 
X-Ray Science Division 

Beamline Technical Support 
 
 
 



 Fast CCD Detector – User Guide 
 

 Page 2 of 22 

 
1.0 How to set up the detector ....................................................................................... 3 
2.0 How to turn on and use the detector ........................................................................ 4 
3.0 Turning off the system ........................................................................................... 10 
4.0 Detector Trigger and Shutter Control .................................................................... 11 
5.0 Using Anaconda board with onboard FPGA to subtract dark image and perform 
data compression ............................................................................................................... 13 
6.0 ImageJ Plug-ins ...................................................................................................... 14 

6.1 How to subtract a dark image from a stack of images ....................................... 14 
5.2 How to removing over scan from a stack of images .......................................... 18 
5.2 How to do ImageJ z-projections......................................................................... 19 

6.0 Storing images at full speed ........................................................................................ 20 



 Fast CCD Detector – User Guide 
 

 Page 3 of 22 

1.0 How to set up the detector 
 
The detector resides on a single cart and consists of the following components. 

• Detector Head 
• Detector Computer 
• Chiller 
• Vacuum Pump 
• Lake Shore Temperature Controller 331 
• FCCD Interlock  
• Detector Power Supply 
• Pulizzo power outlet for Chiller 
• Pulizzo power outlet for FCCD Power Supply 

 

 
 
It is easiest if the whole cart fits into the hutch.  If not you may need to disconnect and 
reconnect the following: 

• Cryo-tiger lines between cryo-head and chiller 
• Camera Link cables between the computer and the detector head 
• Power supply cable between the power supply and the detector head 
• Interlock cable between the interlock and the detector head 

 
Place the detector head where you want it and reconnect. 



 Fast CCD Detector – User Guide 
 

 Page 4 of 22 

2.0 How to turn on and use the detector 
 
 
Once the detector is properly hooked up, do the following: 
 

1. Plug in the two pulizzis, the power strip, and the vacuum pump.  Turn on the 
power strip. And turn on the vacuum pump. 

 
2. Turn on and log into the detector computer 

a) Username: fastccd 
b) Password: xray2Data 

 
3. Verify the fans are on for the back end electronics by holding you hands over the 

vent holes.  If the fans are not on, make sure that the Interlock cable is connected 
to the back panel of the detector (A black connector with a gray cable) and that 
the fan power supply is plugged into the isobar power strip. 
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4. Turn on the interlock module.  This requires turning on the switch in the back, 
then the switch on the front, and then finally pressing a power on button on the 
front panel.  The button is not shown in the image below, but is on the upper left 
side to the right of the board power LED.  After the interlock board is on you need 
to turn on the power to the computer in the box.  This is a small switch in the back 
of the module. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

5. Verify that the Lake Shore Controller is turned on, the set point is at -50 
degree C and that the heater is in its high range.  The interlock box should 
initialize the Lake Shore controller on power up, but it can be done manually too. 

a) To set the temperature press “set point” +/- 50 enter. 
b) To select the heater range press “Heater Range” until high is on the screen, 

then press “enter” 
 
 
 
 

6. Open the Interlock MEDM screen.  This will allow you to monitor two 
temperatures, a pressure and the power status on the Interlock GUI.  When the 
detector is on and running the CCD temperature will be around -50 degree C, 
the Circuit Boards temperature will be around 35 degree C, the Detector Chamber 



 Fast CCD Detector – User Guide 
 

 Page 6 of 22 

pressure will be around .14 mTorr or lower, and the Cooler Power and Board 
Power should both be on.  To Open the MEDM screen: 

a) Double click on the “InterlockMedm” Icon in the top middle of the screen 
 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
      
   Figure 1 - Interlock MEDM Screen 
 

7. Reset the chiller power on the interlock box.  Do this by pressing the Cooler 
Power Reset button on the front of the interlock box.  Three green lights on the 
top pulizzi power strip should now be on.  If not verify that the top pulizzi is 
turned on and in the remote mode. 

 
 
 
 

 
 
 
 
 
 

8. When the pressure is ≤ 8 x 10-4 mtorr, turn on the chiller by flipping the switch 
on the side of the chiller up.  If the vacuum pressure is too high, the interlock 
should turn off the chiller to prevent frost from building up inside the detector.   

 
9. When the lakeshore shows the temperature of -50 degree C from “control A” 

temperature, you can reset the detector power on the interlock box by pressing 
the CCD power reset button on the front of the interlock box.  The three green 
lights on the bottom pulizzo should all be on.  When this is true, the detector 
power supply can be turned on with the switch in the front of the power supply.  
If not verify that the bottom pulizzi is turned on and in the remote mode.  The 
interlock system will prevent the detector from being turned on if the system is 
not under vacuum and not cold enough.   



 Fast CCD Detector – User Guide 
 

 Page 7 of 22 

 
 

 
 
 

10. On the Computer, open the MEDM GUIs by clicking on the MEDM icon.  At 
first all of the fields will be white, until you start up the ioc program.  Once the 
MEDM screens are open start the ioc by pressing on the IOC icon.  Observer the 
text and make sure it comes up properly.  At the end of the boot up you should see 
the message “FCCDSerial: wait: Sending FCCD Configuration file: 
FCCD_config_default.txt” which is followed by “FCCDSerial: NIOS reply: 
InfMod ver 11-21-2008 at 11:15PM” and then  FCCDSerial: DONE SENDING 
FCCD configuration file” 

 
To have the detector start taking images use the Area Detector Control MEDM 
screen.  As an example you could set the Exposure time to 10 msec, the acquire 
period to 200 msec, and the Trigger mode to continuous.  Then in the Acquire 
row press “start”.  You should see the Image counter counting.  These images are 
not saved, but will allow you to look at raw images with Imagej. 
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NOTE: As shown, FCCD_config_defalt.txt is the default configuration file.  It 
may be switch to “1jtw-2x-clocks-voltages-fcrics-Apr07d.txt” for 2x mode.  
(lower gain higher dynamic range) 
 

11. To use ImageJ to view raw images: 
a)  first start ImageJ by clicking on the ImageJ icon.   
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b) From the ImageJ window select Plugins->EpicsCA->epics ca Viewer 
 
 

c)  
 

d) In the Image J EPICS_AD_Viewer Plugin make sure that the PVPrefex is 
set to FCCD1: 

e) If the detector is collecting images you will be able to press the Start 
button.  This will popup an imagej view with the last image captured.  To 
set the Brightness/Contrast you can either press “Shift-C” or from the 
ImageJ window select Image->Adjust->Brightness/Contrast.  Adjust it so 
you can see the image as below. 

 
 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

12. To save a series of images to an IMM file the following steps need to be done. 
a) In the Area Detector Control MEDM screen 

I. In the Acquire row press “Stop” 
II. Set you Exposure time 

III. Set you Acquire period 
IV. Set the # Images to the number of images you want to collect 
V. Make the Image mode = multiple 

VI. You may want to clear the Image counter by typing 0 and 
pressing enter in the Image counter box. 

b) In the FCCD1:IMM MEDM screen 
I. Enter the File path 

II. Enter the File name 
III. You may zero out the Next file by typing 0 and pressing 

enter in the Next file # box 
IV. Set Auto Increment to yes 
V. Set the Write mode to stream 
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VI. Set the # Capture to the number of file you want to write to 
the IMM file.  This should match the # Images written in the 
Area Detector Control MEDM screen 

VII. In the Capture row press Start 
c) In the Area Detector Control MEDM screen press Acquire Start 
d) You should observer the counters in both Medm screens count up until 

they hit the desired number of images.  Then it should stop and the file 
should be written. 

e) To repeat another batch of images one only needs to press Capture Start 
followed by Acquire Start. 

 

3.0 Turning off the system 
 

Do the following steps if the system is being turned off for a couple of days. 
 

1. In the FCCD GUI, put the Exposure Mode in Single mode 
2. In the FCCD GUI, turn off the CCD 
3. In the FCCD GUI, close the serial port 
4. Turn off the CCD Power Supply 
5. Turn off the cryo-tiger chiller 
6. Turn off the Detector 
7. Leave the vacuum pump on 

 
If the system is being turned off for a few hours it is sufficient to just: 

1. In the FCCD GUI, put the Exposure Mode in Single mode 
2. In the FCCD GUI, turn off the CCD 

 
Turning off the system to move it: 

1. In the FCCD GUI, put the Exposure Mode in Single mode 
2. In the FCCD GUI, turn off the CCD 
3. In the FCCD GUI, close the serial port 
4. Turn off the CCD Power Supply 
5. Turn off the cryo-tiger chiller 
6. Wait for the Detector to warm up to room temperature – 1 to 2 hours! 
7. Turn off the vacuum pump AFTER THE DETECTOR IS WARM! 
8. Turn off the Computer 
9. Turn off the Interlock 
10. Unplug all of the power cables 
11. Put the Detector Head back on the Cart.  This may require removing some cables 

and hoses. 
12. Wind up all hoses and cables so that they are not dragging on the floor. 
13. Move detector 
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4.0 Detector Trigger and Shutter Control 
 
The detector can be triggered in a number of different ways. 

1. External trigger with a signal going into a lemo connector on the back of the 
detector. 

2. Software controlled trigger with a PC command 
3. Fixed number of triggers started by either a single software trigger or an external 

Trigger.  The time between triggers is the same specified for the focus mode. 
4. Focus mode which generates a series of triggers with a specified time between 

triggers. 
 
When a trigger happens, its starts an exposure delay and a shutter delay.  Both delays 
have independent range of 0 to 1048575 usec.  At the end of a delay then the exposure 
time or shutter time start.  The exposure and shutter time both have an independent range 
of 0 to 1048575 msec.  It should be noted that if you are using the internal control for the 
time between triggers that the trigger cycle must meet the two conditions below. 
 
Trigger Cycle >= Exposure Delay + Exposure Time + Readout Time 
And 
Trigger Cycle >= Shutter Delay + Shutter Time 
 
The FCCD User GUI below shows how the user can modify the Exposure Mode, and set 
the various parameters. 
 
 
 
 
 
 
NEW GUI HERE 
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A typical way to hook up the detector would be to use an external signal to trigger the 
detector, and then use the shutter signal from the detector to control the shutter.  You can 
define the “Delay between T->E”, “Exposure Time”,  “Delay between T->S” and the 
“Shutter Time” to control you integration time and to synchronize the detector with 
external devices. 
 

LEMO Function 
J10 Trigger Input 
J12 Input – Not Used 
J13 Input – Not Used 
J8 Exposure Output 
J9 Shutter Output 
J11 Shutter Output 
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5.0 Using Anaconda board with onboard FPGA to 
subtract dark image and perform data compression 

 
Below are the steps to perform dark image subtraction with the Coreco anaconda frame 
grabber board: 

1. Start imageJ and run Plugins->EpicsCA->epics ca decomp 
The following window should appear.  Make sure all of the PVs are filled in 
correctly.  This version of the displayer will automatically switch between raw 
images and compressed images. 
 
 

 
 
 
 
 

2. In the Image J Epics CA Plugin press Start.  When there are images being 
captured they will appear in a display.  You can set the background and contrast 
by pressing “Shift & C”.  To start images perform steps 3->6 and press Acquire 
Start. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  

3. In ADBase.adl - Set Exposure time (.010) 
4. In ADBase.adl - Set Acquire period (.020) 
5. In ADBase.adl - Set Image mode = Continuous 
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6. In ADBase.adl – press Acquire Start to take some images and view them in 
imageJ.  Then stop the images by pressing Acquire Stop. 

7. In FPGASEC8.adl put into SumMeanImg.  For some reason SumStdImg mode 
did not work last time I tried it. 

a. When you switch to this mode the Detector state in ADBase will briefly 
change to Waiting.  Wait for the Detector state to go back to Idle before 
continuing. 

8. Set Num Images to Average to 64 or some 2n value.  16 is the minimum number. 
9. In ADBase.adl set the Image counter to 0 by entering 0 and pressing enter.  This 

is just so you can easily see the number of images collected, and is not really 
nessisary. 

10. In ADBase.adl press Image mode = Continuous and Acquire Start 
a. The image counter will count to the number of images you set to average 

and then stop itself. 
b. An image will be saved in the D:\cal directory, and will have a name 

MeanCal_date_time.tif 
11. In FPGASEC8.adl press the Load Image.  It should grab the last image saved to 

the D:\cal director.  You should see Coreco message screen cycles through the 
following states and others I couldn’t read. 

a. Coreco Armed and Ready 
b. FPGA IDLE 
c. Load CCF File 
d. Store Image file 
e. FPGA Store Dark 
f. FPGA PASS 
g. Load CCF file 
h. Coreco Armed and Ready 

12. In FPGASEC8.adl put into DarkSub mode 
13. In ADBase.adl press Acquire Start and observe the dark subtracted images in 

imageJ 
 
To perform real time data compression one needs to perform the steps to capture an 
average dark image (outlined above) and then perform the steps below. 
: 
: 
 

6.0 ImageJ Plug-ins 
 
I have implemented a number of plug-ins in ImageJ for manipulate a stack of images.  
Below I have outlined how to use these plug-ins. 
 

6.1 How to subtract a dark image from a stack of images 
 

1. Start ImageJ 
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2. File -> Import -> Image Sequence 
a. Use the file browser to select a file in a directory 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

b. If more than 1000 files are to be opened, click “Use Virtual Stack” in the 
Sequence Option window. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

c. Open the file to be used as the dark image by clicking File->Open and 
selecting the file in the file browser and pressing “Open”. 

d. Run the Normalize Plug-in by first selecting the stack of images, then run 
Plugins->Normalize.  This will open the window below.  Select the 
DARK Image to subtract, leave the BRIGHT Image Blank, Select 
“Process entire Stack” and then click OK.  This will normalize all of the 
images in the stack. 
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e. To view the images properly you will need to set the brightness and 
contrast.  Image->Adjust->Brightness/Contrast(Ctrl+Shift+C).  This will 
open the window below: 

 
 
 
 
 
 
 
 
 
 
 
 
 

f. Click Set and set the minimum 
display value to 0 and the 
maximum display value to 100.  Alternatively, use the slides. 

g. Note: The slide on the bottom of the image will move you quickly through 
the stack. 
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At this point it might be good to remove the over scan areas.  Do this by following the 
procedure in the next section. 
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5.2 How to removing over scan from a stack of images 
1. Start ImageJ 
2. File -> Import -> Image Sequence 

h. Use the file browser to select a file in a directory 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

i. If more than 1000 files are to be opened, click “Use Virtual Stack” in the 
Sequence Option window. 

 
 
 
 
 
 
 
 
 
 
 
 
 

j. In ImageJ select Plugins->FCCD RemoveOverScan 
k. This will create a new stack of images with the over scan removed.  The 

new images will all start with FCCDClean....  This process needs to be 
made faster! 

l. To make the image look proper the offset and contrast may need to be 
adjusted.  This can be done by selecting Image->Adjust-
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>Brightness/Contrast (Ctrl+Shift+C).  Use the sliders in the window to 
adjust the image pallet.   

 
One could also remove the three noisy ADCs by selecting the plugin “FCCD 
RemoveNoiseAndOS”. 
 
 
 

5.2 How to do ImageJ z-projections 
 
Another useful feature of image J is to look at a pixel-by-pixel projection of a stack with 
the maximum, minimum, or the average values of the pixels for the entire stack.  This can 
be done by selecting: Image->Stacks->Z Project.. 
 

 
 
Click OK. 
This will open up the projection in a new window.   
If you look at the maximum values, it is easy to see zingers that were captured in the 
stack of images. 
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6.0 Storing images at full speed 
 
For now, you can only go at full speed for a fixed number of images equal to the size of 
the storage buffer in the frame grabber.  This is around 1000 images. 
 

1. Set the FCCD User GUI as below: 

 
 
2. Set the Image Server Up 

 
a. Setup-Acquisition – Synchronous, Exosures = 1000, Physical Memory 

Buffer set to 800000 (1422 buffers Allocated) 
b. Setup-Background = None 
c. Setup-File System – TIFF, File Index 1, Desired Directory, 

SpeedTestE1C8$#.tif or some other file name 
d. Next to the Abort button, select “None” from the select menu.  This will 

prevent images from being displayed on the screen. 
e. In the ROIs tab check “Use ROI” and check “Save ROI to file” 
f. Finally press “Acquire” in the Image Server.  The image server will then 

be waiting for 1000 images from the detector.  If you go to the Overview 
tab in the Image Server you can see the number of exposures being 
counted down and what was the last file written. 
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3. Press “Trigger Exposures” in the FCCD GUI. 
 

You should see files being saved in the Image Server.  After 1000 images have been 
saved, the Acquire button in the image server will be come dark again.  This indicats 
that the acquisition is done. 
 
To verify the images were saved without any missing images you can open them up 
with ImageJ.  You may have to select “Use Virtual Stack” if you cannot fit all of the 
images into memory.  The pixel in the upper left corner and lower right hand corner 
contains an image counter from the FCCD detector.  To verify that no images have 
been dropped verify that this counter has been incremented by a 1000.  In image J, 
zoom into the upper left hand corner of the 1st image and move the cursor over the 
pixel.  Look at the main ImageJ window for the value of that pixel.  Then repeat this 
for the last image.  When you subtract the two values, it should be 999.   
 
An example of the screens generated in this process is shown below. 
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Note: 1989 – 990 = 999 
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